summaryrefslogtreecommitdiff
path: root/dev-python/jsonschema-path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-13 18:18:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-13 18:18:15 +0100
commitb8330d80ce605a72596ccfa1bfc087b9ded559b8 (patch)
tree209587b26d39505ff0a0c21c2f20ef51652688e9 /dev-python/jsonschema-path
parent41c2683a5cfac2bd3280dc5d5aaed73b6c377bcf (diff)
gentoo auto-resync : 13:10:2023 - 18:18:15
Diffstat (limited to 'dev-python/jsonschema-path')
-rw-r--r--dev-python/jsonschema-path/Manifest3
-rw-r--r--dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild44
-rw-r--r--dev-python/jsonschema-path/metadata.xml13
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/jsonschema-path/Manifest b/dev-python/jsonschema-path/Manifest
new file mode 100644
index 000000000000..aab1e8a37c1c
--- /dev/null
+++ b/dev-python/jsonschema-path/Manifest
@@ -0,0 +1,3 @@
+DIST jsonschema-path-0.3.1.gh.tar.gz 39698 BLAKE2B b56f3c6c591066781c01ab32674c8fdd6193352208fbe9a3b06cae6e345711532a4abfb3f4433481eeb02a4dc7e884cc280c1b6d247ee1e647d503cea434b4f6 SHA512 00aa61aacb92d3aa11be6b3f5f69f6cb70743559849c425549a6fcc0c8c6eeff9feaef5a07da70308cc03311ca48dda7e35d429fa2a5a1aba9099fe678594038
+EBUILD jsonschema-path-0.3.1.ebuild 985 BLAKE2B a9458a1e6e041338e8152b7fe1bae13c291a8288ed746ab75fa6ece8d9d45a8c4e0306c043f429cdfcb120634521afd9c0fd6de83eccaffd9bfd5b55887b6e90 SHA512 e6fda039a36da1d060e7368d863feaf4f094e199b5724ec500ed1b7b2c03b3ff6a7e86a7845f151cf2c6fbdb18d5cbfc15a6208a69ac13a2fcc6b0b2ef1a8938
+MISC metadata.xml 404 BLAKE2B 1ca43c4b4650286727d5676f4179f99daa52efeeeded543e3453b91033fb68e6639851b1149a93f28b2fec501acc9623bcb2cd2f58d9df59db505a7ce730807c SHA512 0e041011c6459c256ef992aecea2ac5782d608855da7ddf15340e2a66f89c4542078563dd560a03cc5b13df5c85858c4796d74f39f5a9d257d131f758d5a1bd3
diff --git a/dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild b/dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild
new file mode 100644
index 000000000000..364da459eeca
--- /dev/null
+++ b/dev-python/jsonschema-path/jsonschema-path-0.3.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="JSONSchema Spec with object-oriented paths"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema-path/
+ https://github.com/p1c2u/jsonschema-path/
+"
+SRC_URI="
+ https://github.com/p1c2u/jsonschema-path/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pathable-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ # remove random pins due to caret operator
+ sed -i -e 's:\^:>=:' -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/jsonschema-path/metadata.xml b/dev-python/jsonschema-path/metadata.xml
new file mode 100644
index 000000000000..ab4cdeab8d51
--- /dev/null
+++ b/dev-python/jsonschema-path/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jsonschema-path</remote-id>
+ <remote-id type="github">p1c2u/jsonschema-path</remote-id>
+ </upstream>
+</pkgmetadata>