summaryrefslogtreecommitdiff
path: root/dev-python/jsonrpclib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 14:07:47 +0000
commit7c9730bcb62df7cbf8248c5db9a478aac52c60ea (patch)
tree3521ee333c83fb6c7ff14d0a0a2d742464e88767 /dev-python/jsonrpclib
parent29394d0921808a94a409f01eff49f681651de5d5 (diff)
gentoo auto-resync : 17:02:2023 - 14:07:46
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/Manifest2
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild38
2 files changed, 32 insertions, 8 deletions
diff --git a/dev-python/jsonrpclib/Manifest b/dev-python/jsonrpclib/Manifest
index a60ab5dc2a68..503b4112522e 100644
--- a/dev-python/jsonrpclib/Manifest
+++ b/dev-python/jsonrpclib/Manifest
@@ -1,4 +1,4 @@
DIST jsonrpclib-0.4.3.2.gh.tar.gz 63127 BLAKE2B 4301f23a981f00e78f88f78a8f5e8d776985fcd5d268373430b308cd9e2b07d5e1aaae9fa514640275439f4269ecf9ac5a2e42d5c96b870b72e37e4faea7c790 SHA512 718b9a8a49b6f936635ea8e500d16b8d3f42a28e44c4d0bb2bf1e648063ab1107edca93b4f178600a0b36d2e0584cf531f6e9721f5ed6967ea9a160c923103f3
EBUILD jsonrpclib-0.4.3.2.ebuild 1095 BLAKE2B 6b3ad06e60a9d76458d27ecc733e524d94733ed591399b42397a7f5e07c3403787019d970693328e7233f5c012727d5aa2768481a44661efa1fb20146d6dbabe SHA512 67d45824e25db9dae4348b76a1b3b4f0537cab052a1269cf1c38abeb366462221bc425abfa2959305904a4863d4b40ddafb8b6e61d74c7d357134a36d29be84f
-EBUILD jsonrpclib-9999.ebuild 644 BLAKE2B 7be1f1d05de031662cd278037b18bd213dff0b33a09710636e1465286b2056d3d86ac7f6f87b93e935521738979b66faead30d49c5b99182bff62d11bf830512 SHA512 576b79cb3fe22e66842b22102b2d45b2ef6d003eb43759b0844f0cc5a9af78d77ddf6d4f8097579413e5991d874f6dd3a5c966b8bac05f2597c5be394da1e9f5
+EBUILD jsonrpclib-9999.ebuild 1099 BLAKE2B 9c3009cdf77c23d4f23d2a94ca442ea658b334c41c7bc3c3e232bee39c682909882054d2e8a1a56796236df5d377c4ebd09baf5132950c38572d57de44c02626 SHA512 17eda56097744b0bccddfa15b7ac6eb9d24baacaf75efb5215dac71c8e05fd2acb6f642fa5492c677677ff9ba7333af8ed68a06f5f287c19008c518c4e9df1d2
MISC metadata.xml 397 BLAKE2B d4a744e7de758617c06b6ff1b349941fe4d1fce423bdbef1bf0fa57561a0d6da9b670cc9d272f7b855acd682dafec54d8f437c41f8404b6bd012d107ec4a2460 SHA512 ba0c143290d42a04ef762dcfe1203de5f98410ca763cbd034611ba5fc32ae92cfcbf0aadde8ccfbe31a95c4116b9f7c97e5f7fe0c71b29690634929d64fdef81
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index 0e44520cf380..e345b2715d3a 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -10,16 +12,38 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
inherit git-r3
else
- SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~mips ~x86"
+ SRC_URI="
+ https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
fi
DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
-HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+HOMEPAGE="
+ https://github.com/tcalmant/jsonrpclib/
+ https://pypi.org/project/jsonrpclib/
+"
LICENSE="Apache-2.0"
SLOT="0"
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
-distutils_enable_tests setup.py
+ # NB: we need to run this test separately as it breaks
+ # tests/test_server.py::PooledServerTests
+ # see jsonlib.py, get_handler()
+ # the most preferred (first) lib that's in test deps
+ local -x JSONRPCLIB_TEST_EXPECTED_LIB=ujson
+ epytest tests/test_jsonlib.py::TestJsonLibLoading
+}