summaryrefslogtreecommitdiff
path: root/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/jsonrpclib/jsonrpclib-9999.ebuild')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-9999.ebuild38
1 files changed, 31 insertions, 7 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
index 0e44520cf380..e345b2715d3a 100644
--- a/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-9999.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{9..10} )
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
@@ -10,16 +12,38 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/tcalmant/jsonrpclib.git"
inherit git-r3
else
- SRC_URI="https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~mips ~x86"
+ SRC_URI="
+ https://github.com/tcalmant/jsonrpclib/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
fi
DESCRIPTION="python implementation of the JSON-RPC spec (1.0 and 2.0)"
-HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
+HOMEPAGE="
+ https://github.com/tcalmant/jsonrpclib/
+ https://pypi.org/project/jsonrpclib/
+"
LICENSE="Apache-2.0"
SLOT="0"
-RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest
-distutils_enable_tests setup.py
+ # NB: we need to run this test separately as it breaks
+ # tests/test_server.py::PooledServerTests
+ # see jsonlib.py, get_handler()
+ # the most preferred (first) lib that's in test deps
+ local -x JSONRPCLIB_TEST_EXPECTED_LIB=ujson
+ epytest tests/test_jsonlib.py::TestJsonLibLoading
+}