summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-python/jsonpatch
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest4
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.25.ebuild2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.26.ebuild28
3 files changed, 32 insertions, 2 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index fd11c1211efb..d79cf56a160b 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,3 +1,5 @@
DIST jsonpatch-1.25.tar.gz 24340 BLAKE2B 0022b4b0b3a0487958b86f14c1738a32593b8056510e3836e15385874b64f5d243d757c99a146a48da6563f0d9330eb38cb91ad6cde3e0a1b4cb8cbd3b15f9dd SHA512 5e1d5b6dcb6ee847ddd561400fe2d00e07aa1827a63ab98a38cd5e91fa0e52d8635eba1192edbccf9c7b9ce9c7ce0a414d580665c427c87a820e533d26092ad6
-EBUILD jsonpatch-1.25.ebuild 837 BLAKE2B 38a9af2ea62b2ddb74540111d27b533a83f539a05a5621a453f776788d42d68ea060d13447e1b5029e61d6f4fab23b0a19c3f24cf5f1702561a9c8343ef603e0 SHA512 57a33a8c7470bf63d0569af01c796b19dfb076a2e8d09d58da57e9c93b6588690a15aa0780d008636b7bc5f4d488bbb92a7ffc9e41ec66a37a6308cdaf4bd88a
+DIST jsonpatch-1.26.tar.gz 24440 BLAKE2B 345831bd9a9fc1902d0959685ed2dbbc0bf04d191bbc78567d27283e9ae52f7e22f50e9f400461300d1c3388712afa51d4d6a2ddd0a06dbc0a1b576b02bfe807 SHA512 1ab25c8e091cd0b772062a8c448fee4772081d8bd715489b2f7a76e4c0bdff8b26dd38b26c3037cf9bdf8780b97e62a20b6a5bdc43f43af16fdae51d1291bf52
+EBUILD jsonpatch-1.25.ebuild 836 BLAKE2B 6f5bb95ffeff9389bc8ce9db031e5a377ef62e087078faa70106acfd3bef29ec2dd3a3224ec92f5c53cd50ec8cac8c833560d16b02839a487d59f70a70803c3d SHA512 fcbe73e291c0a10303c9d61b04c7bcd6b210ef0ee546153759479665fd7f9b57d2b9194cd72859ca89324ecff2eac900c861b3ecbcc2bf6e10b4c79856fd825f
+EBUILD jsonpatch-1.26.ebuild 840 BLAKE2B 39ff73e16252a6c56d31e50eae213ad5e545f656c96a270d9f4b6617c062d94030f9a7412ebd00b8dc274f7d7a851493899f02994bf2c4edc6bb91dce7e602bf SHA512 c559364bd9a81241d076ade6cdf6b893c3bfb85ccd38856f32f45304a403e6a1887c4a5e21d9835b38e84880c939c3c8f3821bf432f243987dbb6c50c1300439
MISC metadata.xml 679 BLAKE2B ecac7a9a6da1482f0585c29ab1e7f1ea3729dc4c2b4640440b0a1a5eddbbbdc7d2c029c4318ab3645a4025b5e21d11015ec76b21f5b069d49a37bd74dcad6e1f SHA512 37946af836c2d8b521618688ffee4b33c1864751081c1f1cd86442e6eb6cf822cfd9dbc228f834fbd31ca63b1dd24927cdb680076e2bd7ead941558ac1d2e436
diff --git a/dev-python/jsonpatch/jsonpatch-1.25.ebuild b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
index a78accbc67f4..e8cf3b1d7450 100644
--- a/dev-python/jsonpatch/jsonpatch-1.25.ebuild
+++ b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
@@ -13,7 +13,7 @@ S="${WORKDIR}/python-json-patch-${PV}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm64 ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/dev-python/jsonpatch/jsonpatch-1.26.ebuild b/dev-python/jsonpatch/jsonpatch-1.26.ebuild
new file mode 100644
index 000000000000..789683263633
--- /dev/null
+++ b/dev-python/jsonpatch/jsonpatch-1.26.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Apply JSON-Patches like http://tools.ietf.org/html/draft-pbryan-json-patch-04"
+HOMEPAGE="https://github.com/stefankoegl/python-json-patch"
+SRC_URI="https://github.com/stefankoegl/python-json-patch/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/python-json-patch-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )
+"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"
+ "${EPYTHON}" ext_tests.py || die "Tests of ext_tests.py fail with ${EPYTHON}"
+}