summaryrefslogtreecommitdiff
path: root/dev-python/jsonpatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/jsonpatch
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/jsonpatch')
-rw-r--r--dev-python/jsonpatch/Manifest2
-rw-r--r--dev-python/jsonpatch/jsonpatch-1.25.ebuild4
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/jsonpatch/Manifest b/dev-python/jsonpatch/Manifest
index 2bdf13f5949d..fd11c1211efb 100644
--- a/dev-python/jsonpatch/Manifest
+++ b/dev-python/jsonpatch/Manifest
@@ -1,3 +1,3 @@
DIST jsonpatch-1.25.tar.gz 24340 BLAKE2B 0022b4b0b3a0487958b86f14c1738a32593b8056510e3836e15385874b64f5d243d757c99a146a48da6563f0d9330eb38cb91ad6cde3e0a1b4cb8cbd3b15f9dd SHA512 5e1d5b6dcb6ee847ddd561400fe2d00e07aa1827a63ab98a38cd5e91fa0e52d8635eba1192edbccf9c7b9ce9c7ce0a414d580665c427c87a820e533d26092ad6
-EBUILD jsonpatch-1.25.ebuild 838 BLAKE2B fa2a72b4138052873043b50039aec310c1ac78d9658ce0d4c2266b24427c0c6a908695d30eb1632d702d5c5ccba3270aab216f242dd05a8ac88c94b3ece066ac SHA512 43b9e2f0d341d6438418c11d9ce7e3b54859973495f0706424f936d8ea39fbbdc254ded111c2bb354fe0b237490015d0da67ee8f99c1705a46ee975eda325abb
+EBUILD jsonpatch-1.25.ebuild 837 BLAKE2B 38a9af2ea62b2ddb74540111d27b533a83f539a05a5621a453f776788d42d68ea060d13447e1b5029e61d6f4fab23b0a19c3f24cf5f1702561a9c8343ef603e0 SHA512 57a33a8c7470bf63d0569af01c796b19dfb076a2e8d09d58da57e9c93b6588690a15aa0780d008636b7bc5f4d488bbb92a7ffc9e41ec66a37a6308cdaf4bd88a
MISC metadata.xml 679 BLAKE2B ecac7a9a6da1482f0585c29ab1e7f1ea3729dc4c2b4640440b0a1a5eddbbbdc7d2c029c4318ab3645a4025b5e21d11015ec76b21f5b069d49a37bd74dcad6e1f SHA512 37946af836c2d8b521618688ffee4b33c1864751081c1f1cd86442e6eb6cf822cfd9dbc228f834fbd31ca63b1dd24927cdb680076e2bd7ead941558ac1d2e436
diff --git a/dev-python/jsonpatch/jsonpatch-1.25.ebuild b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
index 29d72258211d..a78accbc67f4 100644
--- a/dev-python/jsonpatch/jsonpatch-1.25.ebuild
+++ b/dev-python/jsonpatch/jsonpatch-1.25.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -15,12 +15,12 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm64 ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/jsonpointer-1.9[${PYTHON_USEDEP}]"
BDEPEND="
test? ( ${RDEPEND} )
"
-RESTRICT="!test? ( test )"
python_test() {
"${EPYTHON}" tests.py || die "Tests of tests.py fail with ${EPYTHON}"