summaryrefslogtreecommitdiff
path: root/dev-python/jsonext/jsonext-0.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/jsonext/jsonext-0.4.2.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/jsonext/jsonext-0.4.2.ebuild')
-rw-r--r--dev-python/jsonext/jsonext-0.4.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/jsonext/jsonext-0.4.2.ebuild b/dev-python/jsonext/jsonext-0.4.2.ebuild
new file mode 100644
index 000000000000..51fa8ba1fa13
--- /dev/null
+++ b/dev-python/jsonext/jsonext-0.4.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Well-structured helpers for serializing commonly encountered structures to JSON."
+HOMEPAGE="https://github.com/mbr/jsonext"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND=""