summaryrefslogtreecommitdiff
path: root/dev-python/jsonext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/jsonext
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/jsonext')
-rw-r--r--dev-python/jsonext/Manifest3
-rw-r--r--dev-python/jsonext/jsonext-0.4.2.ebuild22
-rw-r--r--dev-python/jsonext/metadata.xml14
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jsonext/Manifest b/dev-python/jsonext/Manifest
new file mode 100644
index 000000000000..8c24e13387fb
--- /dev/null
+++ b/dev-python/jsonext/Manifest
@@ -0,0 +1,3 @@
+DIST jsonext-0.4.2.tar.gz 9574 BLAKE2B cba417bc116e572f383a6d396d33fab0f6b63534ae89c402b6cfc0297a0c2fce336bf63464252fe9c87a9617f7f00ed82fe9de9d4e95356b60ae555963d4951b SHA512 2b47b48b529ad8f3b9662ce19f6ea9250648e17cb94e4a59a52ab6a9aabf64abb74f3c76a1edf274fe1e52863352456c0f95c5cd7406c44ca917b6addd09a2a7
+EBUILD jsonext-0.4.2.ebuild 590 BLAKE2B ca40238bcf41cb9cc1cfeb0cc18716bb1d244e8d49e6951a70c969c814562c513a9b3f08ae1e561a03f4130460c02cc570f39324be6f1afe8a7786ae27e74ea9 SHA512 252f7f740f8c2e1a3dfdb0b118cc79d03867df3e917e78464c9475db225d01536723f37da0b745e48d36be866defcb3448be295d6d683fea944b6814059e5bf4
+MISC metadata.xml 478 BLAKE2B 917cd38f6d39c8fb63724e545d5a0d76a173b83dd43543dcc0400799c2cfec8966496e8656696947fff61f7fb25cdc4fe64ee73ca787d9072acbbaf376817a9f SHA512 819a01efba7324a2b5dc6829a882b1d8ec22588a0b615abf44a83b1e1ea517b463f1d01fae40c6fa3309ebe15f2797065575e9b34dc53944d7b44f860b36a6ed
diff --git a/dev-python/jsonext/jsonext-0.4.2.ebuild b/dev-python/jsonext/jsonext-0.4.2.ebuild
new file mode 100644
index 000000000000..51fa8ba1fa13
--- /dev/null
+++ b/dev-python/jsonext/jsonext-0.4.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Well-structured helpers for serializing commonly encountered structures to JSON."
+HOMEPAGE="https://github.com/mbr/jsonext"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND=""
diff --git a/dev-python/jsonext/metadata.xml b/dev-python/jsonext/metadata.xml
new file mode 100644
index 000000000000..959c6dbb5909
--- /dev/null
+++ b/dev-python/jsonext/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ jsonext makes it easy to serialize objects outside of the standard Python primitives to JSON.
+ </longdescription>
+</pkgmetadata>