summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/jaraco-path/jaraco-path-3.3.1.ebuild')
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild b/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
new file mode 100644
index 000000000000..d718b3dcdb27
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="https://github.com/jaraco/jaraco.path/"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-8.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+src_prepare() {
+ # use the py3.7+ built-in
+ sed -i -e '/singledispatch/d' setup.cfg || die
+ sed -i -e 's:from singledispatch:from functools:' jaraco/path.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests || die "Tests failed with ${EPYTHON}"
+}