summaryrefslogtreecommitdiff
path: root/dev-python/jaraco-path
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-05 09:25:57 +0000
commit6d691ad5b6239929063441bbd14c489e92e7396e (patch)
treee294f87b1ce66397fee1273bd6c7131aeb586f51 /dev-python/jaraco-path
parentd99093fb4bb5652015c06274d64083daa2439e4f (diff)
gentoo resync : 05.03.2021
Diffstat (limited to 'dev-python/jaraco-path')
-rw-r--r--dev-python/jaraco-path/Manifest3
-rw-r--r--dev-python/jaraco-path/jaraco-path-3.3.1.ebuild40
-rw-r--r--dev-python/jaraco-path/metadata.xml13
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/jaraco-path/Manifest b/dev-python/jaraco-path/Manifest
new file mode 100644
index 000000000000..7f37b3116900
--- /dev/null
+++ b/dev-python/jaraco-path/Manifest
@@ -0,0 +1,3 @@
+DIST jaraco.path-3.3.1.tar.gz 13287 BLAKE2B 8a803269fc02cc85391b4b1e1f2ee2a94c039d433b505aeb4aa0fcbb23731b802f236cd2de80dbb8b9e59297312892a085632f41234d3e1bb7d4bd04f62e00ba SHA512 00dac02fdc6df469f8661d552b16a8ee6150d86a7df9459264377a03e96fd94608f9782ad4cc2b2df67c64a10f8af26ed650b0bac0b1e59607d429abdbe64309
+EBUILD jaraco-path-3.3.1.ebuild 934 BLAKE2B 220ed025f5c99810585e974afb588b91132cf27a0061899feede44dc8a9ebbb16fcc0211bc410ffab0c9c3d8fd50dc296762ba5a8f0b0765c1f0364c439e05c0 SHA512 77f01e7161d28ac47cc9ded14671bb401b7be47f6ad19c616a93ea45fe4bf2471edcca67798c0563ce45e842ac75d1f21493601085403ffede4f4a191469c7d1
+MISC metadata.xml 396 BLAKE2B 3ecf8b1f6392c3d14122458f7b5fc3c08e5693570685a6ad0f29da64e9f38e4e93c83b180fe01803471342343b0420769af6a01086cd71cc3031b2efaaf3b54c SHA512 eb3cdebd2a8d524c88b519d8e4bb6020e63da5cf69cb4f81eb7a7867bc6d880c313afcd8aa7dd6bd82b661e1aabc60c6ea0c4319ad2b2589e1825d8e3ea65de3
diff --git a/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild b/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
new file mode 100644
index 000000000000..d718b3dcdb27
--- /dev/null
+++ b/dev-python/jaraco-path/jaraco-path-3.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="Miscellaneous path functions"
+HOMEPAGE="https://github.com/jaraco/jaraco.path/"
+SRC_URI="mirror://pypi/${PN::1}/${PN/-/.}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-8.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+src_prepare() {
+ # use the py3.7+ built-in
+ sed -i -e '/singledispatch/d' setup.cfg || die
+ sed -i -e 's:from singledispatch:from functools:' jaraco/path.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests || die "Tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/jaraco-path/metadata.xml b/dev-python/jaraco-path/metadata.xml
new file mode 100644
index 000000000000..1a2842629b40
--- /dev/null
+++ b/dev-python/jaraco-path/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jaraco.path</remote-id>
+ <remote-id type="github">jaraco/jaraco.path</remote-id>
+ </upstream>
+</pkgmetadata>