summaryrefslogtreecommitdiff
path: root/dev-python/ini2toml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
commit514c44bb9cc421df9c323acbad430cbb6ee5b89a (patch)
tree22621125c9bc9177d5339f093f57cb928531f33f /dev-python/ini2toml
parent59c2499e0c9720169c9d5a02168c51c807a21467 (diff)
gentoo auto-resync : 15:05:2024 - 00:01:27
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest2
-rw-r--r--dev-python/ini2toml/ini2toml-0.15.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index e079580b3318..ce90b57cd981 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1,3 +1,5 @@
DIST ini2toml-0.14.tar.gz 108296 BLAKE2B f09ac924eea976b82d68b12132cc671cb5b0f57734fc2a4f4b0dc68e0a9e20d4f906ab757e662c152a5d7db9f0bad17bd28644524bd18a16895ad489eac1d29d SHA512 d29155ae1069084381aef852145a6c734ea4e1e8c6847174fff98bca497cbb4289ee791b26541c6027b716845dd23fc251dde531c6cb9c62d490e4bfed5f862e
+DIST ini2toml-0.15.tar.gz 109236 BLAKE2B d844f45e14379af974c86283daa1aa6fa5d9934b219fdf02be9abbeb873487b36eecede39dafc261f5ab2a6bfadceaea3b16611f5d6c1f3bc88a28574a11dc14 SHA512 5726c745972fbdf6a254ccd44133c5c65368f531c17efda3b83323c2c9e450d508fe57f1aa0919c0de6cc6e18d6a974b75dc50ecf29c852d367bc03891f0486c
EBUILD ini2toml-0.14.ebuild 1435 BLAKE2B 92f53f0cc2f89a516b7774c0a29f9f13231ec7e9833ae1193ba9ac783219aa33f718293cfee541371976d898dabd8b6ad82b5f843fe2508a692cda4dad1f9d2d SHA512 14eb944d762cb8b03c45bf4e61e69269fbd9a11c02d66fd93d7f93869a47d57835eec20d6971f9531a2f7fe9fee177877a50f1ea9637a21f0887cceef34d2499
+EBUILD ini2toml-0.15.ebuild 1443 BLAKE2B 76ad8647b95834e2a6a5a7afb32ece4fd0ecfeb7089fb8f8fb3acd708ce62decd64c28001626b251ced7c1f21268366bb711608f2d41232735d45b63f743c789 SHA512 c54fb9a7100d357a6f377d6299f9c06f33740f2d57079a9206018bb3193a4d1425be98418f33c3b22e19e23984329d813dd0de98b3320950a4bcf9ef573e21f7
MISC metadata.xml 374 BLAKE2B d1d096c2db4d1975e07553486be8e1ef66a63338b6a6617f71131565b80f612b9d50ca7c039d0b37b02eec56421231f52833390eb8536de44d4edd7c90d307f2 SHA512 21a272e9c3a7eb3e0950358f8ffb90b961ff0e39073519ed0b36660dfae91b24f8e09e3b89a20dbeadba45d995eea4bb89d484acc04a7251dfb9f33603bef998
diff --git a/dev-python/ini2toml/ini2toml-0.15.ebuild b/dev-python/ini2toml/ini2toml-0.15.ebuild
new file mode 100644
index 000000000000..86e379f5596f
--- /dev/null
+++ b/dev-python/ini2toml/ini2toml-0.15.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Automatically conversion of .ini/.cfg files to TOML equivalents"
+HOMEPAGE="
+ https://pypi.org/project/ini2toml/
+ https://github.com/abravalheri/ini2toml/
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-20.7[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-59.6[${PYTHON_USEDEP}]
+ >=dev-python/tomli-w-0.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/configupdater[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ dev-python/tomlkit[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov ini2toml --cov-report term-missing::' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # validate_pyproject is not packaged
+ tests/test_examples.py
+ )
+ local EPYTEST_DESELECT=()
+
+ # Incompatible with pyproject-fmt-2 API:
+ # https://github.com/abravalheri/ini2toml/issues/103
+ if ! has_version "<dev-python/pyproject-fmt-2[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_cli.py::test_auto_formatting
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}