summaryrefslogtreecommitdiff
path: root/dev-python/ini2toml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-14 00:01:24 +0100
commit59c2499e0c9720169c9d5a02168c51c807a21467 (patch)
tree48c68a8a7e0094b2edaace12850e6c059bc3636b /dev-python/ini2toml
parenta25cc082a26782e5d39ded4559c91ff11bc3c299 (diff)
gentoo auto-resync : 14:05:2024 - 00:01:24
Diffstat (limited to 'dev-python/ini2toml')
-rw-r--r--dev-python/ini2toml/Manifest2
-rw-r--r--dev-python/ini2toml/ini2toml-0.14.ebuild10
2 files changed, 5 insertions, 7 deletions
diff --git a/dev-python/ini2toml/Manifest b/dev-python/ini2toml/Manifest
index ff2c0f97d6b7..e079580b3318 100644
--- a/dev-python/ini2toml/Manifest
+++ b/dev-python/ini2toml/Manifest
@@ -1,3 +1,3 @@
DIST ini2toml-0.14.tar.gz 108296 BLAKE2B f09ac924eea976b82d68b12132cc671cb5b0f57734fc2a4f4b0dc68e0a9e20d4f906ab757e662c152a5d7db9f0bad17bd28644524bd18a16895ad489eac1d29d SHA512 d29155ae1069084381aef852145a6c734ea4e1e8c6847174fff98bca497cbb4289ee791b26541c6027b716845dd23fc251dde531c6cb9c62d490e4bfed5f862e
-EBUILD ini2toml-0.14.ebuild 1434 BLAKE2B 15ed0d2c48df7ff0d358ec5079b47a4f5ca98636f2e5a9869a763e5b8afb317e44a2d5f93587f53b4b83ce347139ba8e3a81bf3e8d5a1ea392719baf61d42d34 SHA512 f3dd0a0d4ae9ba03441a56c21c4c7c04d3c915f37250326e3436ecf0f0139bb0ee3d2fa1d13e34ccee128fa67242795544dde493ed63c2c40b6b006d6651b48b
+EBUILD ini2toml-0.14.ebuild 1435 BLAKE2B 92f53f0cc2f89a516b7774c0a29f9f13231ec7e9833ae1193ba9ac783219aa33f718293cfee541371976d898dabd8b6ad82b5f843fe2508a692cda4dad1f9d2d SHA512 14eb944d762cb8b03c45bf4e61e69269fbd9a11c02d66fd93d7f93869a47d57835eec20d6971f9531a2f7fe9fee177877a50f1ea9637a21f0887cceef34d2499
MISC metadata.xml 374 BLAKE2B d1d096c2db4d1975e07553486be8e1ef66a63338b6a6617f71131565b80f612b9d50ca7c039d0b37b02eec56421231f52833390eb8536de44d4edd7c90d307f2 SHA512 21a272e9c3a7eb3e0950358f8ffb90b961ff0e39073519ed0b36660dfae91b24f8e09e3b89a20dbeadba45d995eea4bb89d484acc04a7251dfb9f33603bef998
diff --git a/dev-python/ini2toml/ini2toml-0.14.ebuild b/dev-python/ini2toml/ini2toml-0.14.ebuild
index cdf1678fcf02..2d64a412ee78 100644
--- a/dev-python/ini2toml/ini2toml-0.14.ebuild
+++ b/dev-python/ini2toml/ini2toml-0.14.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
inherit distutils-r1 pypi
@@ -17,7 +17,6 @@ HOMEPAGE="
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test-rust"
RDEPEND="
>=dev-python/packaging-20.7[${PYTHON_USEDEP}]
@@ -30,9 +29,6 @@ BDEPEND="
dev-python/configupdater[${PYTHON_USEDEP}]
dev-python/tomli[${PYTHON_USEDEP}]
dev-python/tomlkit[${PYTHON_USEDEP}]
- test-rust? (
- >=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]
- )
)
"
@@ -50,7 +46,9 @@ python_test() {
)
local EPYTEST_DESELECT=()
- if ! has_version ">=dev-python/pyproject-fmt-0.4.0[${PYTHON_USEDEP}]"; then
+ # Incompatible with pyproject-fmt-2 API:
+ # https://github.com/abravalheri/ini2toml/issues/103
+ if ! has_version "<dev-python/pyproject-fmt-2[${PYTHON_USEDEP}]"; then
EPYTEST_DESELECT+=(
tests/test_cli.py::test_auto_formatting
)