summaryrefslogtreecommitdiff
path: root/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-27 22:23:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-27 22:23:02 +0100
commit651f415b41664a0fd7f9e83ac1425ba3670c9518 (patch)
tree6edbaa4a890ab8fdc5dd63ad94f2f0e5d25259b0 /dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
parent3529f1bf2739399905cd55b27c7609459bfc069f (diff)
gentoo auto-resync : 27:10:2023 - 22:23:02
Diffstat (limited to 'dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild')
-rw-r--r--dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild10
1 files changed, 1 insertions, 9 deletions
diff --git a/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild b/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
index cdcf6cac54ed..87f340fb4b75 100644
--- a/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
+++ b/dev-python/indexed-gzip/indexed-gzip-1.8.5-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing pypi
@@ -35,14 +35,6 @@ BDEPEND="
distutils_enable_tests pytest
-src_prepare() {
- # strip custom "clean" command that doesn't support "-a"
- # https://bugs.gentoo.org/838955
- # TODO: this can be removed once distutils-r1 stops using clean
- sed -e '/cmdclass/d' -i setup.py || die
- distutils-r1_src_prepare
-}
-
src_compile() {
# This actually enables line tracing, so it fits USE=debug more.
if use debug; then