summaryrefslogtreecommitdiff
path: root/dev-python/graphviz/graphviz-0.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/graphviz/graphviz-0.13.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/graphviz/graphviz-0.13.ebuild')
-rw-r--r--dev-python/graphviz/graphviz-0.13.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/graphviz/graphviz-0.13.ebuild b/dev-python/graphviz/graphviz-0.13.ebuild
index fb28c85097c4..92f9f2c7bf0c 100644
--- a/dev-python/graphviz/graphviz-0.13.ebuild
+++ b/dev-python/graphviz/graphviz-0.13.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -14,21 +14,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="MIT"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="media-gfx/graphviz"
-DEPEND="
+BDEPEND="
app-arch/unzip
test? ( ${RDEPEND}
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
>=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
)
"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-python_test() {
- py.test -v || die
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
}