summaryrefslogtreecommitdiff
path: root/dev-python/graphviz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/graphviz
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest4
-rw-r--r--dev-python/graphviz/graphviz-0.13.ebuild17
-rw-r--r--dev-python/graphviz/graphviz-0.14.1.ebuild33
3 files changed, 44 insertions, 10 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index 40b93d9f5637..d34344b108b3 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1,3 +1,5 @@
DIST graphviz-0.13.zip 181039 BLAKE2B 6484706c706941891500350c933cad537e63b8f6bd602c46d493ac211842bd9762ff25d7b97c8eda9b8f345e20712971e79afbc099087a8db2fcb3e734591b71 SHA512 3401aeebd6b19f487998aeb4cffcf9598ed31a861b6d335fc76295474512068692371b061a83fb001098010813c0ab61a06c3f2c410c9c9d108000a6b2ab6631
-EBUILD graphviz-0.13.ebuild 769 BLAKE2B 55c3b80c90e4d46c4e336bdac80a32a5600a86cc6c2b8d6d65fa131e03f651ab24ad506ab15ad386fc8111b9fa070ab16293decca6bd6117f664165c83dae9f5 SHA512 3a7142eb06d7e41ddfccb5b81d49dcfa53f95091b91abdbbd6e74814e33cdbc8737a7ab3be9bb18daa791b5ab1b3486f8a33867945c507c065ddd00012fb5419
+DIST graphviz-0.14.1.zip 183737 BLAKE2B f4dd100d6fcdfcfc266a7dc77f89b8647ac16d4d56629555ec94b54347b0d91b531ec25ac7ed9c13b0470f6bc49c68a9101791e5fe8b815ab0cd18a9c6f93e7d SHA512 ce2731acecee823afaf086955b316aba956a666b5d528c1ecdee388bf26ee02f502d48d650ed3a8aebcb75ecbff750049c1ca50e27644f74f57fb34b65e42c9a
+EBUILD graphviz-0.13.ebuild 712 BLAKE2B c109d4ff4e571328c7b88cf59727a82b22c14a0ffe499fa04be225a1f3f5b5714956831d297e775f049c324ca02464c4cb9d04171c5440a160f10620432cfc7a SHA512 baead7390ecb362bb8c6c488d4e1d895104fb893134b99b3a1df3fb5a58d3367e70476c26385ef09149bbaaf8a9f3fee380ec1742c12a7fe3488edefcc9741c5
+EBUILD graphviz-0.14.1.ebuild 714 BLAKE2B b729944979869343730ea20ce1fcc9536a714c0f7deca2b75bc5a156ac865972e2dc656e220f6eb339e4aec4942c4e4f9df5b7fcadf555e0c031d47dac83b288 SHA512 d8a4b832aea3751e214b82aed64c9fd6a185123f4e2a519d57b3baf6a7f57abbba11898a0c86e3a7c728afab0b0a58b1b3728d05a907d8115b02256c8183978e
MISC metadata.xml 527 BLAKE2B b9c6fc9921bfbde8dcde78435394cb97b88d65cd6691bffe94d03f5b22127753333a93496b206d7efa7aef31ffce26d7dd212e3f244f9d111bfc006baf4fff42 SHA512 ee156200f5de25536c3de4de57d0cdc0e01fcbf5b3ef8cd0baf15f7aeea29ce178e393c2ff3f409a93ad3dacd099664b9e72c43c259231b59668f08504c21c82
diff --git a/dev-python/graphviz/graphviz-0.13.ebuild b/dev-python/graphviz/graphviz-0.13.ebuild
index fb28c85097c4..92f9f2c7bf0c 100644
--- a/dev-python/graphviz/graphviz-0.13.ebuild
+++ b/dev-python/graphviz/graphviz-0.13.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -14,21 +14,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
LICENSE="MIT"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="media-gfx/graphviz"
-DEPEND="
+BDEPEND="
app-arch/unzip
test? ( ${RDEPEND}
>=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
>=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
)
"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-python_test() {
- py.test -v || die
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
}
diff --git a/dev-python/graphviz/graphviz-0.14.1.ebuild b/dev-python/graphviz/graphviz-0.14.1.ebuild
new file mode 100644
index 000000000000..3700d1003cf8
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.14.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="media-gfx/graphviz"
+BDEPEND="
+ app-arch/unzip
+ test? ( ${RDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}