summaryrefslogtreecommitdiff
path: root/dev-python/gdata
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/gdata
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/gdata')
-rw-r--r--dev-python/gdata/Manifest3
-rw-r--r--dev-python/gdata/gdata-2.0.18.ebuild27
-rw-r--r--dev-python/gdata/metadata.xml12
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/gdata/Manifest b/dev-python/gdata/Manifest
new file mode 100644
index 000000000000..2bd03c544fee
--- /dev/null
+++ b/dev-python/gdata/Manifest
@@ -0,0 +1,3 @@
+DIST gdata-2.0.18.tar.gz 2475552 BLAKE2B 8679667c427aea162a13d56bb6e88d3c092960c3d0b15d4f297b6a96ea63a96373469e875629386d573a0a97024d16ef3d42798749554dc09b621919b98a4f65 SHA512 57d01a8e41fd7507621c10a4ea3e66223aa1d481365269daecdb5ef1bd725915448bcfa5aca9bef3a7fb4b735627d7916b7f971f1c05d7bf840069346e98ceef
+EBUILD gdata-2.0.18.ebuild 838 BLAKE2B 741d1ed1d1ea2ea98a688dd62a539ad66ff2e3ce5b41372e8fe654a395e00df006c506cba8852ce5ef27b519d4403e6ee26f3f3648a6e378f6652b971639e010 SHA512 667b80cab373c7a18b7d33372c89e7637082a952cffc91cd5d6333467e980b4fa3982acb998f31c42fba9d43d2b2c01a0d97f7e026b9c9fd53d40ff450a0ff54
+MISC metadata.xml 374 BLAKE2B 8034fd862b60a12ddf48ae0f61c5cd7b4c8f5f537e8ab6e2d5e8a826889d39f106e96c03114c5f99a265cedb2277fdead21316a39722fe3d7925f5aa594aa4e5 SHA512 d4c66573bcdb0cf9b1f9c61539180de94c57853fbd6241c4049247ca745779284072b39087d90b79ed79f83504dc0551fbc0c62b9a52b5572ae1681af97c41dc
diff --git a/dev-python/gdata/gdata-2.0.18.ebuild b/dev-python/gdata/gdata-2.0.18.ebuild
new file mode 100644
index 000000000000..a90fa6858bee
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="ssl(+),xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="https://github.com/google/gdata-python-client https://pypi.org/project/gdata/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="examples"
+
+python_test() {
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ "${PYTHON}" tests/run_data_tests.py -v || die "Test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/gdata/metadata.xml b/dev-python/gdata/metadata.xml
new file mode 100644
index 000000000000..84c76180c346
--- /dev/null
+++ b/dev-python/gdata/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">google/gdata-python-client</remote-id>
+ <remote-id type="pypi">gdata</remote-id>
+ </upstream>
+</pkgmetadata>