summaryrefslogtreecommitdiff
path: root/dev-python/gdata/gdata-2.0.18.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/gdata/gdata-2.0.18.ebuild')
-rw-r--r--dev-python/gdata/gdata-2.0.18.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/gdata/gdata-2.0.18.ebuild b/dev-python/gdata/gdata-2.0.18.ebuild
new file mode 100644
index 000000000000..a90fa6858bee
--- /dev/null
+++ b/dev-python/gdata/gdata-2.0.18.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+PYTHON_REQ_USE="ssl(+),xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python client library for Google data APIs"
+HOMEPAGE="https://github.com/google/gdata-python-client https://pypi.org/project/gdata/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="examples"
+
+python_test() {
+ # run_service_tests.py requires interaction (and a valid Google account), so skip it.
+ "${PYTHON}" tests/run_data_tests.py -v || die "Test failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+ distutils-r1_python_install_all
+}