summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-15 00:01:28 +0100
commit514c44bb9cc421df9c323acbad430cbb6ee5b89a (patch)
tree22621125c9bc9177d5339f093f57cb928531f33f /dev-python/exceptiongroup
parent59c2499e0c9720169c9d5a02168c51c807a21467 (diff)
gentoo auto-resync : 15:05:2024 - 00:01:27
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest4
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild24
2 files changed, 14 insertions, 14 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index e83f15be4878..f2951207e2f5 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,3 +1,3 @@
-DIST exceptiongroup-1.2.1.gh.tar.gz 28203 BLAKE2B 65068805670105246c84115a4030641eeff0384df01fc6b7ebd3215c7933908d8db8c8e272efd056b3f044110bf285d3fd477002e0db4c8f99f83bea71f28ce4 SHA512 6f1f29e017192f5881f28855692ad41fe781846b5daa082699350c8dd5990bc3aa54751e1776c620a3a48bf5a8d5bd9b4b50f09d848051b00ba19d825116e7a7
-EBUILD exceptiongroup-1.2.1.ebuild 877 BLAKE2B cdc9d481d957ff25684061c2ae8c48e950896b2046ccc3e432674a688f60b8a6fe4bc1892b6ec1e43e4fccf5f98b136597ad82635d75c877fb4a2f385f77af80 SHA512 26edd90ca44b576960aad544049b665ce88e44dd30c0f684fe2315e51d6c3a13829c41e337b87d73cf8e73f475d861302ce6f9a62f8f1b5e4aff48c9387dbadb
+DIST exceptiongroup-1.2.1.tar.gz 28717 BLAKE2B 70e8093ad6af81343bf90e349671265e612f12fe25e5caeaef5917353159415215e4bb1921d9a0fcde6c3bd1a31a84f032827a2d5d8884daea777d7b110d8995 SHA512 7e0216ac2d76f0b3d29a0690790aa98d8e0f019eaee74e37e4ddcb97553a6a4d5037982478e663e8dfba49731444decda06122a3cb68f1c538589f5b43bdebfc
+EBUILD exceptiongroup-1.2.1.ebuild 789 BLAKE2B 82351661933a4cdc062d7995d52e0ffedbaf88f53a98739290bad516742a81e01c820a6232320ec3aa00c031be6943b651084fc469714ed8066b6de90f8e9c43 SHA512 4ba2b394bb3ab3c0cc1549ca3cbe96d419354acf5a090546b249090bb73a8aa2c0d9bafed84d23eeca5426752f19fa8415c9ac1f14e66dbb4513a7f9346c320e
MISC metadata.xml 384 BLAKE2B 248abcb5fc08c91396cdbff52e5c3e4f6cce2aa273cfd52b48ee13de9ccdaecd09e9a436ed79f258d15d8d4583fe5995e054010c909a522f47e6866e55b3458f SHA512 c631c69438059cb2a6c80e595e45fac904d32dfb53f8be183142f1195d3a3b9bc14bc240f0808e14f47d31beb1887ad82ee79c5f1847c8e6b59dbfeea7913c8b
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
index 0623e77dea45..112639c10e38 100644
--- a/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
+++ b/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
@@ -4,23 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=flit_scm
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 pypi
-MY_P=${P/_}
DESCRIPTION="Backport of PEP 654 (exception groups)"
HOMEPAGE="
https://github.com/agronholm/exceptiongroup/
https://pypi.org/project/exceptiongroup/
"
-# pypi sdist does not include tests as of 1.1.1
-# https://github.com/agronholm/exceptiongroup/pull/59
-SRC_URI="
- https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
LICENSE="MIT PSF-2.4"
SLOT="0"
@@ -28,9 +20,17 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
-
python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # https://github.com/agronholm/exceptiongroup/issues/122
+ tests/test_formatting.py
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}