summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild')
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
index 0623e77dea45..112639c10e38 100644
--- a/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
+++ b/dev-python/exceptiongroup/exceptiongroup-1.2.1.ebuild
@@ -4,23 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=flit_scm
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
-inherit distutils-r1
+inherit distutils-r1 pypi
-MY_P=${P/_}
DESCRIPTION="Backport of PEP 654 (exception groups)"
HOMEPAGE="
https://github.com/agronholm/exceptiongroup/
https://pypi.org/project/exceptiongroup/
"
-# pypi sdist does not include tests as of 1.1.1
-# https://github.com/agronholm/exceptiongroup/pull/59
-SRC_URI="
- https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
LICENSE="MIT PSF-2.4"
SLOT="0"
@@ -28,9 +20,17 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv
distutils_enable_tests pytest
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
-
python_test() {
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # https://github.com/agronholm/exceptiongroup/issues/122
+ tests/test_formatting.py
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}