summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
commit22f5aa1d3324a28622ae4bc828ee77ee079edbb8 (patch)
tree9dda4f0e2d4085105a470d17b1d6dc04cf4ed6fe /dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
parent8e2875c48ca3030fa53717c6fb773b63eba7ca6d (diff)
gentoo auto-resync : 13:03:2023 - 06:14:36
Diffstat (limited to 'dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild')
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
new file mode 100644
index 000000000000..3091487c0fe0
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+# pypi sdist does not include tests as of 1.1.1
+# https://github.com/agronholm/exceptiongroup/pull/59
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}