summaryrefslogtreecommitdiff
path: root/dev-python/exceptiongroup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-13 06:14:36 +0000
commit22f5aa1d3324a28622ae4bc828ee77ee079edbb8 (patch)
tree9dda4f0e2d4085105a470d17b1d6dc04cf4ed6fe /dev-python/exceptiongroup
parent8e2875c48ca3030fa53717c6fb773b63eba7ca6d (diff)
gentoo auto-resync : 13:03:2023 - 06:14:36
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest2
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index d265b783b5b7..ceaa47e3ed1a 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1,3 +1,5 @@
DIST exceptiongroup-1.1.0.gh.tar.gz 22724 BLAKE2B 2de748494fe1356353b7f70d3afc7be7ecb8df4166f57461459c7f463bc5c22340c9073b0b0e032a52680560e37e4004c754fb4ddcc1a5a70f8dd0e973b1d8a9 SHA512 588b4ec3cae01a64140aac191cbdf8d0631eb614d430bbdbd02d17d8ff43aad9d233c3545694c6fffb622a2b3c38a289e20f1b8db6bf0e9b8819d668e38a87e3
+DIST exceptiongroup-1.1.1.gh.tar.gz 23107 BLAKE2B d68778e4a4d14add65ee2300fd15308c17b2cae1733bf4e8938e88b5cf76b9f19d8f9c102c06298769ff9541ded02868763d9c4aac776d22f78c250ea2d942ce SHA512 eb072fef6160cc6d332ae6e08ee7a34ce478188d143f97daae3f8251a8253a7b460249a121af27d66953ff8000ea5ef43a6dee145b14ba7b2968790132a766bf
EBUILD exceptiongroup-1.1.0.ebuild 774 BLAKE2B 019d538b5f362ad08c5238307b73e34cc93462c5d93a6144ef1b57531981be679b141517db504efa3d33ea617146cf981369473d2812e5867e79fd92d7f21ae5 SHA512 005f29aefc604aba23037b06737135bc8f3193f305eff7ab363b9e10e7c2fe6bb2b95f22fa29b3726bc3e29aa0ae6c898a6f3f3f0a0467516c1af30e503ce8ee
+EBUILD exceptiongroup-1.1.1.ebuild 884 BLAKE2B 61a4aa61bd45474809f18a9954dc7fbc121a1fb6754cfd217b80bde94fcf9ec75ff993e7342ddfe22b16df7dda9d2a77cb43a4039e7e7c04c4b02d1d4f0adadc SHA512 2ce5a6f151f30087f08b45edb61063fdee84a0af2a04625bcb2271c290868520792e44cffea44389107970630a6c3e78146c43999e42107f249844c72bb7e9a7
MISC metadata.xml 384 BLAKE2B 248abcb5fc08c91396cdbff52e5c3e4f6cce2aa273cfd52b48ee13de9ccdaecd09e9a436ed79f258d15d8d4583fe5995e054010c909a522f47e6866e55b3458f SHA512 c631c69438059cb2a6c80e595e45fac904d32dfb53f8be183142f1195d3a3b9bc14bc240f0808e14f47d31beb1887ad82ee79c5f1847c8e6b59dbfeea7913c8b
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
new file mode 100644
index 000000000000..3091487c0fe0
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+# pypi sdist does not include tests as of 1.1.1
+# https://github.com/agronholm/exceptiongroup/pull/59
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}