summaryrefslogtreecommitdiff
path: root/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild')
-rw-r--r--dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
index 97128a013059..c9cfa0e96b43 100644
--- a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
+++ b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="Clone of EditorConfig core written in Python"
@@ -43,11 +43,8 @@ python_install() {
#use cli || rm -f "${D}/${EPREFIX}"/usr/bin
}
-src_test() {
- __src_test_run_python_impl() {
- cmake -DPYTHON_EXECUTABLE="${PYTHON}" . || die "tests failed to build with ${EPYTHON}"
- ctest . || die "tests failed with ${EPYTHON}"
- }
- python_foreach_impl __src_test_run_python_impl
- unset __src_test_run_python_impl
+python_test() {
+ cmake -DPYTHON_EXECUTABLE="${PYTHON}" . ||
+ die "tests failed to build with ${EPYTHON}"
+ ctest . || die "tests failed with ${EPYTHON}"
}