summaryrefslogtreecommitdiff
path: root/dev-python/editorconfig-core-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/editorconfig-core-py
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/editorconfig-core-py')
-rw-r--r--dev-python/editorconfig-core-py/Manifest2
-rw-r--r--dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild13
2 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/editorconfig-core-py/Manifest b/dev-python/editorconfig-core-py/Manifest
index 3e23a2f2988f..375dfa99d4a3 100644
--- a/dev-python/editorconfig-core-py/Manifest
+++ b/dev-python/editorconfig-core-py/Manifest
@@ -1,5 +1,5 @@
AUX editorconfig-core-py-0.12.0-no-cli.patch 503 BLAKE2B 98c71ac5fba08ee58d83dba92c37ce4a1d232d96b5f0648102da5b749f382af93b45a59b73d7a81c322937dfc94566f45b6203bea3b286ed49e81b69fa590667 SHA512 3c8802b4df1799c5456e30cf2f62d8c7d5b939a935bd511e2b1dc4ee681131ea7da114038e67efc1938b2c4c110c11dd4cbee0b77024d311e9b50585c364b591
DIST editorconfig-core-py-0.12.0.tar.gz 24801 BLAKE2B 10901b1595965139dbc3aa3227f335c2128b2ea83204ed88b0e799021f7c215fd13c3e2246cb9197ecb7c918aca2d6e9269d94298aa0665432ab091630a29dd6 SHA512 29c5f58bd7293052e4b1fbfbadcf4a148eb939558494d599bafd46151a4fb5af9cd07dcef477db9a709a0ea63dec0dd7e9d4071779f8ca6e3bd137268cc22f72
DIST editorconfig-core-test-abb579e00f2deeede91cb485e53512efab9c6474.tar.gz 7900 BLAKE2B 9ebdb5e522948bc9e86ea84435ccaa11585a8a12f4cd6fe54c64d78917281c913568351767d8077623b1196d84206d1c2d0126a0510f70df484c1b55d829028b SHA512 ae5424b4926d6cb127cb3da473400ced4f7ccf224f7baa8bc5bde0317cc045bb7b99738a56efe5fd0e5a0fbe39b997b9fb1739d24713e7f83b58e987c5e56a32
-EBUILD editorconfig-core-py-0.12.0.ebuild 1363 BLAKE2B 89ffc4327a3e3517c0bf6bb02186985b3e1f6ab6598f557d7168143b7fa89dee0feba2249db86ad550c28e2b11b27582c6297a2794a9b3af25cbcdd7ca3d9381 SHA512 e0564cf1153f58059c6ec3148fec620544d4f8bb74d5e19837f7b4c463c965a246a1442933ec42fa4cc98bc48ec960d067f141560e7039e6593474c634e5622f
+EBUILD editorconfig-core-py-0.12.0.ebuild 1255 BLAKE2B 8394b78150c8aaad8989494b920ab2f85f46487554674d6b69e33ee9340f6f05886aced8477dd779f5bfc071c0b01eebace89995163166b22d5af6f08ce9d516 SHA512 34ba2e0a9ea5c0328394563575b5f3c7af8fcd90bde02187a79ca4b2db48f62466128efb5b14d1c8a9c1d7752d8d061ef100bee6c64e70bdd7691d086fdd7acc
MISC metadata.xml 679 BLAKE2B e9d5e33c647f61258a1d8a691f98716030cf425e1b4279a6b05a0151dfc7ec4298ae2070f60316a983618eb9628b5e3c8e1149783cd7768547f8624cec504a87 SHA512 ebac6fb7f09e22832a5436aba0b445775800d377a794c0a5b32302f2d3baf0c6c09d70685bcd12f21e084b290915a43d729cd94b8e92246259446aa17548710b
diff --git a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
index 97128a013059..c9cfa0e96b43 100644
--- a/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
+++ b/dev-python/editorconfig-core-py/editorconfig-core-py-0.12.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
TESTVER="abb579e00f2deeede91cb485e53512efab9c6474"
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
DESCRIPTION="Clone of EditorConfig core written in Python"
@@ -43,11 +43,8 @@ python_install() {
#use cli || rm -f "${D}/${EPREFIX}"/usr/bin
}
-src_test() {
- __src_test_run_python_impl() {
- cmake -DPYTHON_EXECUTABLE="${PYTHON}" . || die "tests failed to build with ${EPYTHON}"
- ctest . || die "tests failed with ${EPYTHON}"
- }
- python_foreach_impl __src_test_run_python_impl
- unset __src_test_run_python_impl
+python_test() {
+ cmake -DPYTHON_EXECUTABLE="${PYTHON}" . ||
+ die "tests failed to build with ${EPYTHON}"
+ ctest . || die "tests failed with ${EPYTHON}"
}