summaryrefslogtreecommitdiff
path: root/dev-python/diskcache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/diskcache
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/diskcache')
-rw-r--r--dev-python/diskcache/Manifest3
-rw-r--r--dev-python/diskcache/diskcache-2.8.3.ebuild41
-rw-r--r--dev-python/diskcache/metadata.xml12
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
new file mode 100644
index 000000000000..b42d695f567a
--- /dev/null
+++ b/dev-python/diskcache/Manifest
@@ -0,0 +1,3 @@
+DIST diskcache-2.8.3.tar.gz 438587 SHA256 61ccc77a51a3e3b31abfb80de7163ba51ce09b1612e0d026f1c0457575c23002 SHA512 d96ac76dfb68cb817febd3f4ed8927a8409c02b13b4112a739528cade40f9a588c732dfc3148392dd12676380c3a2b006ee63b86f30ad70f5d205273003bf23d WHIRLPOOL 0ad78c98a64ae59661eb08c842cb363b42f076e856c1eca8c516bb6b14856c6391afc8a2d5e01bfe0e20fe88e20b8967dbd7cda51785e13e7c6b1dd9947930fd
+EBUILD diskcache-2.8.3.ebuild 835 SHA256 7acc3be261e89d05ead0ce7d08d90ea0c6c89485e19c231d8fe5198df478173f SHA512 6a4cf34d327443a155b22951f975bc9dba34d6c2da5cbc2ac6f620088147ad01fd35136051516d6c11aa1b31e8002ab7fe10e24067c16c6b1520e643ac5590ac WHIRLPOOL 86468ba7e6cd408c9a9d007aa07aee56c5a9217e267e5fcd1f5992de4a670c448d31206aa10d74657ed509f7732f0a7be6fbc075fc55f2cb5bc3500bdfc2ddef
+MISC metadata.xml 391 SHA256 cf1d3d976cf6eb05f2636e2c9d9064f85ec561d0fc55b72fb52c535275f41f16 SHA512 0d088c14dbbf7c11541b5f47d193280c0f92f8f1b3ec62c8aad49648b3fbcc393ce639b5b9ae18533a4d4b9cb5ad536a5a847b705e2b4bd385d3b90d48f812ec WHIRLPOOL 6d29118acc202a920f81dd62f05482a84ec03835bd34ea80cca93cca550e560d32d2c18bbda18c7b6f778de7817b29e0c7eefe4edd63ef29dd930d8cfe5b6821
diff --git a/dev-python/diskcache/diskcache-2.8.3.ebuild b/dev-python/diskcache/diskcache-2.8.3.ebuild
new file mode 100644
index 000000000000..8dba94ae6c0a
--- /dev/null
+++ b/dev-python/diskcache/diskcache-2.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "failed with ${PYTHON}"
+}
diff --git a/dev-python/diskcache/metadata.xml b/dev-python/diskcache/metadata.xml
new file mode 100644
index 000000000000..bda6b340bb5b
--- /dev/null
+++ b/dev-python/diskcache/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">diskcache</remote-id>
+ <remote-id type="github">grantjenks/python-diskcache</remote-id>
+ </upstream>
+</pkgmetadata>