summaryrefslogtreecommitdiff
path: root/dev-python/diskcache/diskcache-2.8.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/diskcache/diskcache-2.8.3.ebuild')
-rw-r--r--dev-python/diskcache/diskcache-2.8.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/diskcache/diskcache-2.8.3.ebuild b/dev-python/diskcache/diskcache-2.8.3.ebuild
new file mode 100644
index 000000000000..8dba94ae6c0a
--- /dev/null
+++ b/dev-python/diskcache/diskcache-2.8.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ nosetests -v || die "failed with ${PYTHON}"
+}