summaryrefslogtreecommitdiff
path: root/dev-python/dill/dill-0.3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-23 08:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-23 08:52:39 +0100
commitc9aaa2ff911ee95adca22bcd9264e8ecfa3d5149 (patch)
tree32153e53b9929840fafd6a0bf95110df4c2885df /dev-python/dill/dill-0.3.7.ebuild
parentbc8e1f28a81cb6ef9bc3fd1103842690c4320ce4 (diff)
gentoo auto-resync : 23:07:2023 - 08:52:38
Diffstat (limited to 'dev-python/dill/dill-0.3.7.ebuild')
-rw-r--r--dev-python/dill/dill-0.3.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/dill/dill-0.3.7.ebuild b/dev-python/dill/dill-0.3.7.ebuild
new file mode 100644
index 000000000000..2a35ac28460a
--- /dev/null
+++ b/dev-python/dill/dill-0.3.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of Python (almost)"
+HOMEPAGE="
+ https://github.com/uqfoundation/dill/
+ https://pypi.org/project/dill/
+"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" -m dill.tests || die
+}