summaryrefslogtreecommitdiff
path: root/dev-python/dill
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-23 08:52:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-23 08:52:39 +0100
commitc9aaa2ff911ee95adca22bcd9264e8ecfa3d5149 (patch)
tree32153e53b9929840fafd6a0bf95110df4c2885df /dev-python/dill
parentbc8e1f28a81cb6ef9bc3fd1103842690c4320ce4 (diff)
gentoo auto-resync : 23:07:2023 - 08:52:38
Diffstat (limited to 'dev-python/dill')
-rw-r--r--dev-python/dill/Manifest2
-rw-r--r--dev-python/dill/dill-0.3.7.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dill/Manifest b/dev-python/dill/Manifest
index 5275ade608de..9d6a26ccf0ae 100644
--- a/dev-python/dill/Manifest
+++ b/dev-python/dill/Manifest
@@ -1,3 +1,5 @@
DIST dill-0.3.6.gh.tar.gz 171608 BLAKE2B 3b0c6f20218230685c91c10edb4d9bfdbb913464903ce03c92c85ad607ab3973c61c39f9a9807d55c1d3aa3736f5de4575e5beb0784f2b17f0af850210bebd61 SHA512 921bd5122b9b90fd3426a7af5fc8ba70d09b92d740951f5db5d481abb280915d722410f174ab028134acff9a3659899c8f315242caa7a44d8e4b38dd02bb1fa3
+DIST dill-0.3.7.gh.tar.gz 176315 BLAKE2B 8c98c40458035e42c078c79df14e474c35a2a6ff4f61d3cfca8f4dfa5a7756512b7d5af6276becd88315c01d88c8562de02b6f9dff06d0161df3e6f6694c7cc8 SHA512 33ec55dc32c9ddf275ce6e502187949bbc7ecc6d24560e132a7bed23e93254b771d38e59c4b6313bbfc25313305c43c6cba2fe07763a93238e1ba66c4bbd8cd4
EBUILD dill-0.3.6.ebuild 646 BLAKE2B 51009350e78044f592c682e6450dabbce3ad03e4e91bbd559e9d2978f69dd9b997fbedf1ef4e4ba0a31816a41d0728c193730439ba88609e7337b24028341d6a SHA512 4a5b9fb9ed0df23c7239a8d3532b1a0455aa1098a8964120085fc513abc7c26ba98dc26951c4c1023c91281b1695383fee2ee5afd7650603ac13598fa2f415a9
+EBUILD dill-0.3.7.ebuild 655 BLAKE2B d072e20a3b2e8be7e8566fd95e6481f6ea566831e62e28b7129980eb8657d62892d09854ccc73e53895ff52f1bb8c4f921f8a810c4194dbef8768ebe488f058c SHA512 bf5c3ee843578d0a1911d74bfc76a5b2b3e4c4e98ffae1ee4677f113214fe2c91ac75450be797cb544ecd36bcb9f74795bf428ad186bd2e306891b42c7235d94
MISC metadata.xml 997 BLAKE2B ae32cd96d7a4967a9886d4903e21720459c0a963a675d301c2bb651fdb15877d845100822c1e7a7b6184ccaa666cbb6dc58f939616de9c1c22554670d841bd19 SHA512 e3dc363382bea8ed76343b62377c139ad84011a6b804f64b65d93941a7c192c268c0da273c73d5ec1cece7320b15fa88bf5a2f20a628d8845efddab24f3acc5b
diff --git a/dev-python/dill/dill-0.3.7.ebuild b/dev-python/dill/dill-0.3.7.ebuild
new file mode 100644
index 000000000000..2a35ac28460a
--- /dev/null
+++ b/dev-python/dill/dill-0.3.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Serialize all of Python (almost)"
+HOMEPAGE="
+ https://github.com/uqfoundation/dill/
+ https://pypi.org/project/dill/
+"
+SRC_URI="
+ https://github.com/uqfoundation/dill/archive/${P}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" -m dill.tests || die
+}