summaryrefslogtreecommitdiff
path: root/dev-python/dict2xml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-14 11:36:24 +0000
commit3a5772102e4f2b6f9cc46f461c90970060ae0c5e (patch)
treed5aebb2508413a75408fd60bd4cb2c886b78ba89 /dev-python/dict2xml
parentf7379fa6ffb6e47eabc62d0d832a5bcad1db9591 (diff)
gentoo auto-resync : 14:02:2024 - 11:36:23
Diffstat (limited to 'dev-python/dict2xml')
-rw-r--r--dev-python/dict2xml/Manifest3
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild25
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.5.ebuild23
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/dict2xml/Manifest b/dev-python/dict2xml/Manifest
index 82947facfbcc..7339f75a9b26 100644
--- a/dev-python/dict2xml/Manifest
+++ b/dev-python/dict2xml/Manifest
@@ -1,3 +1,6 @@
DIST dict2xml-1.7.4.tar.gz 14333 BLAKE2B 9d1a5180d6cffed171aa973902d6e88190b8bd90cd9e4d86744b5c074d82e45c7571763aa9cca67d190cf7af1b1fdd155cbff906a44a638dcb3a7033f1be86ba SHA512 13a2b34783e5f6414c173059ba16a2061ecaef41355b7b0099546d704c9c28b1e0f9ea3186d4b0db99083e66a2f22e69e57a4a415b72c00fd1e17bcb435e7462
+DIST dict2xml-1.7.5.tar.gz 14958 BLAKE2B 1907003e3a27a8e1c1a0e7ab1d5c72b310c46e7af7d51f6a1743ca018fb6a070b0b54b4b24afd8c78dd18f83f9f6950031c0076eae83ccc309a341a0df153708 SHA512 88a77fcdc2ec320ba1668b27da4aacfcfc817090aebabc01fce76bff51b316166a0cc1f053884e8012a28e7118449f901465703869245dc662f29cee9665157e
EBUILD dict2xml-1.7.4.ebuild 541 BLAKE2B 8d46e87c2e9340aa83e204de93ca2a8b5c072e94997a95c533f6dd83333b27f3ee1f19be711b6a4525526c0893d8b26d2081f346eec8b110b5d79045a7e6af4a SHA512 007fa24f511354bb8d30961ef6d61fa28cc39593a906618315659c220dc118e755be821b575b1892830ddeb715095024101a36d26e3a2b04fee17e8c149e3019
+EBUILD dict2xml-1.7.5-r1.ebuild 506 BLAKE2B b56e7aa1bb1b583e9dbfa0e3239994ccfb078b6ef1dc262f116bc28cea60ed2c68f1bc97533f0f9b6ecdf679792d5176768ce437b2a45dec744b61dd71da1a6f SHA512 bc25d93b419c7a278230c981808a47a14bb9250771890221ded2af9502e90c54832093e80c140627f8b785ef3eedae27518caebe4c8d9bc6924eef490edf8d68
+EBUILD dict2xml-1.7.5.ebuild 542 BLAKE2B 4d26e8b860a321621638cfd20967afc5e9fb70d0582043d8bde8de74957dd73f4a3a371a1848ed63f9d2142c257a86ea57300016b586dcc4ef6278aed9b0c169 SHA512 a4474f84f07b5ae17065db483813b66ed7b4806fe1d84b0dbc2ad8ee03276b012ca45787e915559291516818ae5d6aa5f4c87bbf22ee85d9502ec0c920ba2efa
MISC metadata.xml 483 BLAKE2B 590704cfc7c04bef7ac3b4b01677c743887a19c842597a81a12d374c0126ac4feb5ecf3ee6a1b2ee8bb866a2823ecd5e4c556f3ddf512bff00d047d40ee33929 SHA512 175a0080449e7a29aae0398303911acf868bc9a444eb2883d4cca071ac1daafda2ad352274c33516fe06f11ce8bdc029d1e277a8455a3819ff51650388ed11cd
diff --git a/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild b/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
new file mode 100644
index 000000000000..116ec71f6081
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ dev-python/noseofyeti[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/dict2xml/dict2xml-1.7.5.ebuild b/dev-python/dict2xml/dict2xml-1.7.5.ebuild
new file mode 100644
index 000000000000..b23f9330ef96
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# dict2xml uses noseOfYeti for its test, which is not yet available.
+RESTRICT="test"
+
+distutils_enable_tests pytest