summaryrefslogtreecommitdiff
path: root/dev-python/dict2xml/dict2xml-1.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/dict2xml/dict2xml-1.7.5.ebuild')
-rw-r--r--dev-python/dict2xml/dict2xml-1.7.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/dict2xml/dict2xml-1.7.5.ebuild b/dev-python/dict2xml/dict2xml-1.7.5.ebuild
new file mode 100644
index 000000000000..b23f9330ef96
--- /dev/null
+++ b/dev-python/dict2xml/dict2xml-1.7.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Small utility to convert a python dictionary into an XML string"
+HOMEPAGE="
+ https://github.com/delfick/python-dict2xml/
+ https://pypi.org/project/dict2xml/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# dict2xml uses noseOfYeti for its test, which is not yet available.
+RESTRICT="test"
+
+distutils_enable_tests pytest