summaryrefslogtreecommitdiff
path: root/dev-python/cypari2/cypari2-2.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 14:43:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 14:43:50 +0100
commit7e8f2c69a019131eaeb989242d022260ea5a84ff (patch)
treece769e693cf5ee40c03b9eb7ee9ea91e24645947 /dev-python/cypari2/cypari2-2.1.4.ebuild
parent1e8bc3b2037289b8577740cea9321c37c52a49a2 (diff)
gentoo auto-resync : 26:10:2023 - 14:43:50
Diffstat (limited to 'dev-python/cypari2/cypari2-2.1.4.ebuild')
-rw-r--r--dev-python/cypari2/cypari2-2.1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/cypari2/cypari2-2.1.4.ebuild b/dev-python/cypari2/cypari2-2.1.4.ebuild
new file mode 100644
index 000000000000..97c339f4b723
--- /dev/null
+++ b/dev-python/cypari2/cypari2-2.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=standalone
+DISTUTILS_EXT=1
+
+inherit distutils-r1
+
+DESCRIPTION="Cython interface to PARI"
+HOMEPAGE="https://github.com/sagemath/cypari2"
+
+# We're only using Github for v2.1.4 because PyPI is lagging:
+# https://github.com/sagemath/cypari2/issues/143
+SRC_URI="https://github.com/sagemath/${PN}/releases/download/${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sci-mathematics/pari[gmp,doc]
+ dev-python/cysignals[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-regen-bindings-for-each-python.patch" )
+
+python_test(){
+ cd "${S}"/tests || die
+ "${EPYTHON}" rundoctest.py || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}