summaryrefslogtreecommitdiff
path: root/dev-python/cypari2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 14:43:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 14:43:50 +0100
commit7e8f2c69a019131eaeb989242d022260ea5a84ff (patch)
treece769e693cf5ee40c03b9eb7ee9ea91e24645947 /dev-python/cypari2
parent1e8bc3b2037289b8577740cea9321c37c52a49a2 (diff)
gentoo auto-resync : 26:10:2023 - 14:43:50
Diffstat (limited to 'dev-python/cypari2')
-rw-r--r--dev-python/cypari2/Manifest4
-rw-r--r--dev-python/cypari2/cypari2-2.1.4.ebuild39
-rw-r--r--dev-python/cypari2/files/cypari2-2.1.4-regen-bindings-for-each-python.patch40
-rw-r--r--dev-python/cypari2/metadata.xml27
4 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/cypari2/Manifest b/dev-python/cypari2/Manifest
new file mode 100644
index 000000000000..7663579594c2
--- /dev/null
+++ b/dev-python/cypari2/Manifest
@@ -0,0 +1,4 @@
+AUX cypari2-2.1.4-regen-bindings-for-each-python.patch 1337 BLAKE2B e3223252db7834088400d9b1856ef9c15a63e3375847445cdcfd3d8a9e735c1d238e508ff2913825f4a0834e1e4e8b9468151d5bb77a2ed087309d54b183cc7c SHA512 a4588ffa8d9d2ec6e9bcab76876540e5e0da2bb9b56f927825737d030bf938e5fe10f84bca61dc2277f9842bca02db2c87c46c136565e5ef37b2190ce45d9029
+DIST cypari2-2.1.4.gh.tar.gz 127038 BLAKE2B 0d4998841a9a630ea062d7096845771a9a250ed66b68f99988ded6442724559089e8dbbce13ef5c6ad467705c65b2ac9fc5889fa9c40b9665083af558280b81a SHA512 b5926281037aebb899c1a433a0ca106cdfafcb8cb7abb863268ff8151dbc52ee21dbe1d09dde632de1640a4cc4d37f59bebb0e379d61ac2fbdf9fffcf3ba4775
+EBUILD cypari2-2.1.4.ebuild 928 BLAKE2B 33e3954ee8bdeb3917999bfa254f2bf7d5432884d1e2714c41bfbf6f86328717d63e3b66c9671799f3bbcd6c04ce076f3e51c925fd8fded77bf2c47448f32dc8 SHA512 bc6d5199926b0eaa7cb0c0c27b65fabe54dd694bd39130a2059a288fbbe172bc6c63b0a89caeeae0063524dfc8a7b1a77e91b83f60a271d4ab5c4b93c32919bb
+MISC metadata.xml 763 BLAKE2B bd41f69c681be66fb8d70d606f9dcaf586fd5b37399a1ce9bbb97eb3b2042272f681ed15d9f8e0654b34323672aaff784582a81c28f40e41385450ab233000ab SHA512 c9d7fc5d6ea9f9b4d995710f642aad46d83b3ba3222f089b601d4653e7e79966803c8d0b82683df232e44c2aee79219c4bf3965cff63265bbe480f4dcd03cf02
diff --git a/dev-python/cypari2/cypari2-2.1.4.ebuild b/dev-python/cypari2/cypari2-2.1.4.ebuild
new file mode 100644
index 000000000000..97c339f4b723
--- /dev/null
+++ b/dev-python/cypari2/cypari2-2.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=standalone
+DISTUTILS_EXT=1
+
+inherit distutils-r1
+
+DESCRIPTION="Cython interface to PARI"
+HOMEPAGE="https://github.com/sagemath/cypari2"
+
+# We're only using Github for v2.1.4 because PyPI is lagging:
+# https://github.com/sagemath/cypari2/issues/143
+SRC_URI="https://github.com/sagemath/${PN}/releases/download/${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="sci-mathematics/pari[gmp,doc]
+ dev-python/cysignals[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}/${P}-regen-bindings-for-each-python.patch" )
+
+python_test(){
+ cd "${S}"/tests || die
+ "${EPYTHON}" rundoctest.py || die
+}
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}
diff --git a/dev-python/cypari2/files/cypari2-2.1.4-regen-bindings-for-each-python.patch b/dev-python/cypari2/files/cypari2-2.1.4-regen-bindings-for-each-python.patch
new file mode 100644
index 000000000000..cb9ba55fdd29
--- /dev/null
+++ b/dev-python/cypari2/files/cypari2-2.1.4-regen-bindings-for-each-python.patch
@@ -0,0 +1,40 @@
+Ensure that the file auto_paridecl.pxd is both (re)generated with and
+installed for each python implementation.
+
+From 248d26e3e6b1c02fdd3391f033e29d7012189d9e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fran=C3=A7ois=20Bissey?= <frp.bissey@gmail.com>
+Date: Tue, 28 Apr 2020 09:42:39 +1200
+Subject: [PATCH] move rebuild out of build_ext so it is run before everything
+
+---
+ setup.py | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 099ed3b..473fe12 100755
+--- a/setup.py
++++ b/setup.py
+@@ -13,6 +13,10 @@ from autogen.paths import include_dirs, library_dirs
+
+ ext_kwds = dict(include_dirs=include_dirs(), library_dirs=library_dirs())
+
++# Generate auto-generated sources from pari.desc
++# This needs to be done before build/build_ext so the generated pxd is moved
++# to the build directory and installed with newer setuptools.
++rebuild()
+
+ if "READTHEDOCS" in os.environ:
+ # When building with readthedocs, disable optimizations to decrease
+@@ -29,9 +33,6 @@ if "READTHEDOCS" in os.environ:
+ # Adapted from Cython's new_build_ext
+ class build_ext(_build_ext):
+ def finalize_options(self):
+- # Generate auto-generated sources from pari.desc
+- rebuild()
+-
+ self.directives = {
+ "autotestdict.cdef": True,
+ "binding": True,
+--
+2.26.2
+
diff --git a/dev-python/cypari2/metadata.xml b/dev-python/cypari2/metadata.xml
new file mode 100644
index 000000000000..f70554e6dfce
--- /dev/null
+++ b/dev-python/cypari2/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+
+ <maintainer type="person" proxied="yes">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">cypari2</remote-id>
+ <remote-id type="github">sagemath/cypari2</remote-id>
+ </upstream>
+</pkgmetadata>