summaryrefslogtreecommitdiff
path: root/dev-python/contourpy/contourpy-1.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 11:31:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 11:31:39 +0100
commit1afe1c223c048ca2c33fa230c83d620c04fecb8f (patch)
tree0a84fe08d8d4da38c52a26399f94ee584e7b01c6 /dev-python/contourpy/contourpy-1.0.5.ebuild
parentb946f2614a0d5afb20da123a7f13d120cb623d2f (diff)
gentoo auto-resync : 24:09:2022 - 11:31:39
Diffstat (limited to 'dev-python/contourpy/contourpy-1.0.5.ebuild')
-rw-r--r--dev-python/contourpy/contourpy-1.0.5.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/contourpy/contourpy-1.0.5.ebuild b/dev-python/contourpy/contourpy-1.0.5.ebuild
new file mode 100644
index 000000000000..9ccea39952a2
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # threaded algorithms are known to be broken
+ # https://github.com/contourpy/contourpy/issues/163
+ epytest -k "not threaded and not threads"
+}