summaryrefslogtreecommitdiff
path: root/dev-python/contourpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 11:31:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 11:31:39 +0100
commit1afe1c223c048ca2c33fa230c83d620c04fecb8f (patch)
tree0a84fe08d8d4da38c52a26399f94ee584e7b01c6 /dev-python/contourpy
parentb946f2614a0d5afb20da123a7f13d120cb623d2f (diff)
gentoo auto-resync : 24:09:2022 - 11:31:39
Diffstat (limited to 'dev-python/contourpy')
-rw-r--r--dev-python/contourpy/Manifest3
-rw-r--r--dev-python/contourpy/contourpy-1.0.5.ebuild47
-rw-r--r--dev-python/contourpy/metadata.xml12
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/contourpy/Manifest b/dev-python/contourpy/Manifest
new file mode 100644
index 000000000000..e6dbd8b46332
--- /dev/null
+++ b/dev-python/contourpy/Manifest
@@ -0,0 +1,3 @@
+DIST contourpy-1.0.5.gh.tar.gz 12153420 BLAKE2B 1b3899831938c114480606f0c2ef2962248721884cd2be727f2bd11d12d322e7652c7b63860f4c5d8bd039a7e838f3f360dd1af017219caa97dfc63d69ef7e19 SHA512 47dc08f02920cb0ffc081f313dd041fa36e2fd0a81530374ae77adc288af13cf2c526fc1f45d06ef1c256c4c8fe243e0b36b54d3fff7d4f8bd6f9f4938d3c805
+EBUILD contourpy-1.0.5.ebuild 1008 BLAKE2B c8624b30bc1be86de01fad3fb5ab7d335c90bb2e7172ba4a9715dc5c2738730d26be70fecf7a8ce95269017e6be3dca1a1a6e0e02680473b8f880c0a7580dbcc SHA512 45b4c11631bdc03deaa46b4bdc846adaad5bc9db59f070ab5e710c6fedd70be65a778512dc7228d54939a27ad46c050fc7bdd480af01593ee0646ef59acf7aab
+MISC metadata.xml 372 BLAKE2B de3d6cc9d8727bf43be63fdbb8aa2ad375667d189019e189be262e39d028acab98a21e200798c2d5c5c72521aa7d38202e3e235dd44de9b43a7dc9e045d50c47 SHA512 e692f94d805d7f56fc895a4c76dfbacf2f068d687b9191482b946445baa3bd0a685eda7a1b0aec2aaf9a02e6f23d87f0bf22d90f42e3c21d930724c635ff859a
diff --git a/dev-python/contourpy/contourpy-1.0.5.ebuild b/dev-python/contourpy/contourpy-1.0.5.ebuild
new file mode 100644
index 000000000000..9ccea39952a2
--- /dev/null
+++ b/dev-python/contourpy/contourpy-1.0.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for calculating contours in 2D quadrilateral grids"
+HOMEPAGE="
+ https://pypi.org/project/contourpy/
+ https://github.com/contourpy/contourpy/
+"
+SRC_URI="
+ https://github.com/contourpy/contourpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.16[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # linters
+ tests/test_codebase.py
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # threaded algorithms are known to be broken
+ # https://github.com/contourpy/contourpy/issues/163
+ epytest -k "not threaded and not threads"
+}
diff --git a/dev-python/contourpy/metadata.xml b/dev-python/contourpy/metadata.xml
new file mode 100644
index 000000000000..ebd4ed83a551
--- /dev/null
+++ b/dev-python/contourpy/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">contourpy/contourpy</remote-id>
+ <remote-id type="pypi">contourpy</remote-id>
+ </upstream>
+</pkgmetadata>