summaryrefslogtreecommitdiff
path: root/dev-python/commentjson/commentjson-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/commentjson/commentjson-0.9.0.ebuild
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/commentjson/commentjson-0.9.0.ebuild')
-rw-r--r--dev-python/commentjson/commentjson-0.9.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/commentjson/commentjson-0.9.0.ebuild b/dev-python/commentjson/commentjson-0.9.0.ebuild
new file mode 100644
index 000000000000..51fdc6a6b383
--- /dev/null
+++ b/dev-python/commentjson/commentjson-0.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Add Python and JavaScript style comments in your JSON files"
+HOMEPAGE="
+ https://pypi.org/project/commentjson/
+ https://github.com/vaidik/commentjson/"
+SRC_URI="
+ https://github.com/vaidik/commentjson/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lark-parser[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # remove unnecessary version bind
+ sed -i -e '/lark-parser/s:,<0.8.0::' setup.py || die
+ distutils-r1_src_prepare
+}