summaryrefslogtreecommitdiff
path: root/dev-python/commentjson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-29 10:15:54 +0100
commit9aa80713372911cec499b3adb2cd746790920916 (patch)
treeb8e99dc5dd60ac2094a27cc52f74aada8df38f05 /dev-python/commentjson
parentb4d43e8c611df4a8061b6f88d9e9f6b1e3c83903 (diff)
gentoo resync : 29.06.2021
Diffstat (limited to 'dev-python/commentjson')
-rw-r--r--dev-python/commentjson/Manifest3
-rw-r--r--dev-python/commentjson/commentjson-0.9.0.ebuild34
-rw-r--r--dev-python/commentjson/metadata.xml11
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/commentjson/Manifest b/dev-python/commentjson/Manifest
new file mode 100644
index 000000000000..c36c2d21b246
--- /dev/null
+++ b/dev-python/commentjson/Manifest
@@ -0,0 +1,3 @@
+DIST commentjson-0.9.0.gh.tar.gz 15297 BLAKE2B a857b0fa5551079d3d37bff94fb51a903e998c4fb84e0f62a5de28d6eafe0cb8a38b3215515e72c56de0cddb661f109921c801d15b9ba93771290135adaaa5b1 SHA512 cd3d28adecbc445ed3faed7847c65a23829f408cf8aa3fa85544a0f0cf9fa5544b8aff560725cf51921f249123daf9ce9953069e99ca64a312bb4bff652512fe
+EBUILD commentjson-0.9.0.ebuild 746 BLAKE2B 08d352060235204766c8c869ccc0387930c379920ad81f9c2b8905ddfca5ff1c4afb5469d1c6baa2552323a3442264b1c1f1708016691fcff866aabc99690a5b SHA512 04af3ef2cb1341e2802fef5c575a95b484062a2734fc88646cc3a0bde798318a197f5a2afb568c0b09f39db329595988d219a3cddbbcd478062d1a2fc85083e7
+MISC metadata.xml 350 BLAKE2B a14a2adc21600c7f65c10bd0d741c0f81ede15baa200532ad346a74f36e4eed3bfd4af40ae30d208bd6cb1064936b4e7fc5acb0db31890a9e7109210f499b3df SHA512 558f86dfd9c937dec4a41df69e50662a86968cf1884484fc0fbe336d95b4fb4c66c22ced5b086024364d8c02aef6ffac436aa6ba80afc5398dcbf3ac12f5f4d0
diff --git a/dev-python/commentjson/commentjson-0.9.0.ebuild b/dev-python/commentjson/commentjson-0.9.0.ebuild
new file mode 100644
index 000000000000..51fdc6a6b383
--- /dev/null
+++ b/dev-python/commentjson/commentjson-0.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Add Python and JavaScript style comments in your JSON files"
+HOMEPAGE="
+ https://pypi.org/project/commentjson/
+ https://github.com/vaidik/commentjson/"
+SRC_URI="
+ https://github.com/vaidik/commentjson/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lark-parser[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # remove unnecessary version bind
+ sed -i -e '/lark-parser/s:,<0.8.0::' setup.py || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/commentjson/metadata.xml b/dev-python/commentjson/metadata.xml
new file mode 100644
index 000000000000..f4168a14251e
--- /dev/null
+++ b/dev-python/commentjson/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">commentjson</remote-id>
+ <remote-id type="github">vaidik/commentjson</remote-id>
+ </upstream>
+</pkgmetadata>