summaryrefslogtreecommitdiff
path: root/dev-python/colour/colour-0.1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-10 01:02:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-10 01:02:07 +0000
commita2219cb0f7891a8fa42ccd9541809c62ce695216 (patch)
tree6261bca3eb2f8c460f2945176ac4eaee444dcdb2 /dev-python/colour/colour-0.1.5-r1.ebuild
parentf03f06fb7152586e3084ebabe54d93f28da8bf6d (diff)
gentoo auto-resync : 10:01:2024 - 01:02:07
Diffstat (limited to 'dev-python/colour/colour-0.1.5-r1.ebuild')
-rw-r--r--dev-python/colour/colour-0.1.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/colour/colour-0.1.5-r1.ebuild b/dev-python/colour/colour-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..b4e991316597
--- /dev/null
+++ b/dev-python/colour/colour-0.1.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python color representations manipulation library"
+HOMEPAGE="
+ https://github.com/vaab/colour/
+ https://pypi.org/project/colour/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # Upstream uses dead & broken d2to1, just make a quick flit config
+ # to make it work.
+ cat > pyproject.toml <<-EOF
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "colour"
+ version = "${PV}"
+ description = "${DESCRIPTION}"
+ EOF
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --doctest-modules
+}