summaryrefslogtreecommitdiff
path: root/dev-python/colour
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-10 01:02:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-10 01:02:07 +0000
commita2219cb0f7891a8fa42ccd9541809c62ce695216 (patch)
tree6261bca3eb2f8c460f2945176ac4eaee444dcdb2 /dev-python/colour
parentf03f06fb7152586e3084ebabe54d93f28da8bf6d (diff)
gentoo auto-resync : 10:01:2024 - 01:02:07
Diffstat (limited to 'dev-python/colour')
-rw-r--r--dev-python/colour/Manifest1
-rw-r--r--dev-python/colour/colour-0.1.5-r1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/colour/Manifest b/dev-python/colour/Manifest
index f95e5d2efd49..b7e3385ae27b 100644
--- a/dev-python/colour/Manifest
+++ b/dev-python/colour/Manifest
@@ -1,4 +1,5 @@
AUX colour-setup.patch 148 BLAKE2B 41fbf09fa54d8ba88a7b01c240bbb9b26b14f48ecd8d677d5acd16e41d53151f8a443857353be6c593506176e4786caa0001602289add34012e59a463e3c9200 SHA512 2def5f03812b78297fab62f9b7233f32e1923d845f495e1fe3ec18988b30d04b2f6c8908122c87c1738cdec6ac6665c1a41b422fd9a654d08e29ecfa16590eb9
DIST colour-0.1.5.tar.gz 24776 BLAKE2B 71e2b44c6379f73fa1a70781ae2559e37122e2db982d1f98ab5c4432b4e95a2c60d6489a88025499c36d288f3e9269e65caf9560d7772e2c1c050266c284816f SHA512 09a5160862bf10cd5f4a94e43c63d6f2a5db43bcaae0e9d8f66900113ec04471e22d0bec7412f0289c6f1e6871c1a544f5be36266aa8d6fd5ec274bd461d9df8
+EBUILD colour-0.1.5-r1.ebuild 842 BLAKE2B 1e2bf4791d849194483eefd976ab48b49c2e5984880d10501062d13fa19b23dc500777545a0d6a9c432f6de8121c32393d5beeb7d53d8da90bf9f8ec3dba5dce SHA512 229767e65194ee9acd9c45b747898f5de93a7d38fbb3679cfdb4ea50d7fc7d09305456fbc47d57b9e2238ea027db186830154ca196d05750b56e661c379ebaea
EBUILD colour-0.1.5.ebuild 559 BLAKE2B 21597b7c217ad71470e3ef8e486265d678cc236179b8166a1721e19b92cfe5ed9af18d4eb18296766f2438439fff8784b880cdac1bdbef5d526fa693952b675f SHA512 064d30fd20b8a68f3bdc1eb74f111dbf2d7899dd6a8a32bac69ea14b01a246c5d8fa5ddd9a0bc5e5986809c84c66c4839fc7cf9f843b063443017ee5bdc2f3d5
MISC metadata.xml 1154 BLAKE2B e070d8ad663acfe733698b9bc4cc807a232e7a320f0a50864c327792fe5faf1e2e45f7a6676ac9f62bfa2fe88816faa9032691ec0a617c10e1ca4e9f21ba40c1 SHA512 881477f5a9e6ef75bb460044baff36e6b586bea8b8d43307f0a7c07738485bf20144db6a7f8196c8c68e45ec80299a9439a4aff53d152b669de4735969eee5b9
diff --git a/dev-python/colour/colour-0.1.5-r1.ebuild b/dev-python/colour/colour-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..b4e991316597
--- /dev/null
+++ b/dev-python/colour/colour-0.1.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python color representations manipulation library"
+HOMEPAGE="
+ https://github.com/vaab/colour/
+ https://pypi.org/project/colour/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # Upstream uses dead & broken d2to1, just make a quick flit config
+ # to make it work.
+ cat > pyproject.toml <<-EOF
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "colour"
+ version = "${PV}"
+ description = "${DESCRIPTION}"
+ EOF
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --doctest-modules
+}