summaryrefslogtreecommitdiff
path: root/dev-python/clang-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-06 02:09:04 +0100
commit51f0d16e058c162dbce0f93d871ba45683b0ab3a (patch)
tree8dd3bc53a0d23549a8f210ce4bfdf74b36b9319f /dev-python/clang-python
parent35bf81c760d4e362615c32e69329ef61a01281f7 (diff)
gentoo auto-resync : 06:08:2022 - 02:09:04
Diffstat (limited to 'dev-python/clang-python')
-rw-r--r--dev-python/clang-python/Manifest1
-rw-r--r--dev-python/clang-python/clang-python-16.0.0.9999.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/clang-python/Manifest b/dev-python/clang-python/Manifest
index 2b39984efb29..996d649e2922 100644
--- a/dev-python/clang-python/Manifest
+++ b/dev-python/clang-python/Manifest
@@ -4,4 +4,5 @@ DIST llvmorg-13.0.1.tar.gz 147290251 BLAKE2B 2a44b012a672501761d0c27c6b3a315b69b
EBUILD clang-python-13.0.1.ebuild 925 BLAKE2B 1dab0cbb672643072e7d824a262c81505d19e555f24f97f82156473affc2f5ba6fc34ec493ffeedbc82feb1245fc6a39126e1b81fcdc8f8b4ddd0b7fe108e4bb SHA512 11eaf5c7a484d756f01986eacce19c912666518892f3213ff42367c126c2d8474abf6608cca24e6250c64e7423464e7cb3e58c2b069c7febf4893b249f2ee304
EBUILD clang-python-14.0.6.ebuild 956 BLAKE2B 491c8335c64484034663fd84ca2397e13afdd8cab6d3b4adfcc9317379e7a3620372ffe5996d4a0029a7d412f11a0d598f741a6893803ebadba85d330e49682a SHA512 4ef0d1ab2cbc3d277d4cced33fa87de7c3d43295a60a3b418ad4a95399e8de8c2e1e5c594681bf7ce1bfc465732d34b2db3a9e8636c0ed124ddf79c8ed7a5750
EBUILD clang-python-15.0.0.9999.ebuild 935 BLAKE2B d1b871cd5604ded49427be7bbd4453b30b11515c6befc0d4202bb5602c387e41b789a6e14eebefc2a55723a1b4f683a82d41de4bdcbbdfdd85117f5ce64674c4 SHA512 e55abe1dfb64dc1d85c564013d1a01da128cbcb252aa118529ef61b8f0f17a0ae8653ef757a0b59f1b7d45e887951fdcc242bdc1cedaf9b1628047e4a33678cb
+EBUILD clang-python-16.0.0.9999.ebuild 935 BLAKE2B d1b871cd5604ded49427be7bbd4453b30b11515c6befc0d4202bb5602c387e41b789a6e14eebefc2a55723a1b4f683a82d41de4bdcbbdfdd85117f5ce64674c4 SHA512 e55abe1dfb64dc1d85c564013d1a01da128cbcb252aa118529ef61b8f0f17a0ae8653ef757a0b59f1b7d45e887951fdcc242bdc1cedaf9b1628047e4a33678cb
MISC metadata.xml 299 BLAKE2B 2feead2cd1b35b3a43335ddd7711f8181b52bc63ee7166608914260c67528add5251349063afbef4f8cf0ec09b2cd4c3ffdd90f2c14ed60bb69ebc03888f6333 SHA512 cd745c54ab18d25bdaff18582105072574103a36cfe7c175ef740f266d00e9fc6f44c332904d23b911c939cf5bdf52973b388923099d8dd5dfef3c283b5cb685
diff --git a/dev-python/clang-python/clang-python-16.0.0.9999.ebuild b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
new file mode 100644
index 000000000000..2891edc42793
--- /dev/null
+++ b/dev-python/clang-python/clang-python-16.0.0.9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit llvm.org python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+DEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+
+LLVM_COMPONENTS=( clang/bindings/python )
+llvm.org_set_globals
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}