summaryrefslogtreecommitdiff
path: root/dev-python/chardet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /dev-python/chardet
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'dev-python/chardet')
-rw-r--r--dev-python/chardet/Manifest3
-rw-r--r--dev-python/chardet/chardet-3.0.4.ebuild22
-rw-r--r--dev-python/chardet/files/chardet-3.0.4-pytest-4.patch23
3 files changed, 33 insertions, 15 deletions
diff --git a/dev-python/chardet/Manifest b/dev-python/chardet/Manifest
index 351f83a45083..735be534e879 100644
--- a/dev-python/chardet/Manifest
+++ b/dev-python/chardet/Manifest
@@ -1,3 +1,4 @@
+AUX chardet-3.0.4-pytest-4.patch 802 BLAKE2B 64992866c2f101b41f525a0f8cf642774850211f434b471dcfa5aaadcabd5ceb573d5b902f6cdecc2f651a71dc8955204f13beb8a5261d4d0ff3aa6703a4266d SHA512 ca99abb30e8e221b43b7467cfa385c0abb16addd4befd149e35208278a25faf07dd99edd20595be4d0d0d0afdf81602b47e0110f4e9335ef90f5b4c41b54b0ab
DIST chardet-3.0.4.tar.gz 1872214 BLAKE2B b93e2d3e0b5a5c35affa5e3ee661323029f79837a1222d8f69db72911301d9490c9788d2effc577eeeb2a50334cc855afc4bdf4b8dbafb143fcc411d93b824a9 SHA512 b433ea0e15e200df968e6d61c671c42fbd77e519eb033035c4a5c241e1f98e1dfaea6747af632788507583b3ef85b00d510b3f6ef5cf58589ceca1b3a088b357
-EBUILD chardet-3.0.4.ebuild 985 BLAKE2B 8e8f40d39aa77ab7e711dfd8b86a789389dc483be2dfa71ae017c0b24d1ca9a8eafab9e0bbca394a9eef93b45607e3d1bd0adacd14fb7578c3b73f734b554507 SHA512 c8d759f7aaf51a75b9515351929b906d2ca65367213fa4392af8d9b27708fb9271112de3280a1d065f5027e0d579369b514cd53fc0d792d99e27ee5a56647d5c
+EBUILD chardet-3.0.4.ebuild 915 BLAKE2B bd5afda062113bf0cfbeb8e030134ef792039e00525894befeab09dee5aec822de2e8d602e622afc4bc08b4ced52ab1cdfe88830c2f0c1c98c45ea9d409453ff SHA512 a22cc9171b12e26e09d072777bc299151ab3d462b6dd58b6ee7cd3129329d835a60f6c11d69c3d1ae38c39f8ff4687f75ff25817744af572cffd74ad768d47c9
MISC metadata.xml 377 BLAKE2B 8aa19a889e96303024d469c969a9e47613cabd1456b0e21888a02a091049e09a53c6faa3d0e128b5ea21b68f521cede9cf09b570f2fba7a4299187a44e40b018 SHA512 c48c3874a248049fc2845d0a64ee5b94c705ef58158f882f30bbdc561f311a7203cd8979e067a5b0f3f034c95cc4b6da373cea6efc9616f3dabc574772874650
diff --git a/dev-python/chardet/chardet-3.0.4.ebuild b/dev-python/chardet/chardet-3.0.4.ebuild
index c929783b3e22..6dce19acd095 100644
--- a/dev-python/chardet/chardet-3.0.4.ebuild
+++ b/dev-python/chardet/chardet-3.0.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
inherit distutils-r1
@@ -17,20 +17,14 @@ SRC_URI="https://github.com/chardet/chardet/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
"
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-4.patch
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/chardet/files/chardet-3.0.4-pytest-4.patch b/dev-python/chardet/files/chardet-3.0.4-pytest-4.patch
new file mode 100644
index 000000000000..eef88e9e9960
--- /dev/null
+++ b/dev-python/chardet/files/chardet-3.0.4-pytest-4.patch
@@ -0,0 +1,23 @@
+From 0561ddcedcd12ea1f98b7ddedb93686ed8a5ffa4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Tue, 12 Mar 2019 18:44:36 +0100
+Subject: [PATCH] Support pytest 4, don't apply marks directly to parameters
+
+Fixes https://github.com/chardet/chardet/issues/173
+---
+ test.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test.py b/test.py
+index 9833307..ad2b753 100644
+--- a/test.py
++++ b/test.py
+@@ -59,7 +59,7 @@ def gen_test_params():
+ full_path = join(path, file_name)
+ test_case = full_path, encoding
+ if full_path in EXPECTED_FAILURES:
+- test_case = pytest.mark.xfail(test_case)
++ test_case = pytest.param(*test_case, marks=pytest.mark.xfail)
+ yield test_case
+
+