summaryrefslogtreecommitdiff
path: root/dev-python/chardet/chardet-3.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/chardet/chardet-3.0.4.ebuild')
-rw-r--r--dev-python/chardet/chardet-3.0.4.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/dev-python/chardet/chardet-3.0.4.ebuild b/dev-python/chardet/chardet-3.0.4.ebuild
index c929783b3e22..6dce19acd095 100644
--- a/dev-python/chardet/chardet-3.0.4.ebuild
+++ b/dev-python/chardet/chardet-3.0.4.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
inherit distutils-r1
@@ -17,20 +17,14 @@ SRC_URI="https://github.com/chardet/chardet/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- )
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
"
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-4.patch
+)
+
+distutils_enable_tests pytest