summaryrefslogtreecommitdiff
path: root/dev-python/bottle/bottle-0.12.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
commitd37f8725bb68034ef10d8882fb4411a49f2f666e (patch)
tree2b530ee04815bacc1dc051db24c2727d3056b77b /dev-python/bottle/bottle-0.12.24.ebuild
parent171d09fa1f429aa43835c618a2c21753ad5209a4 (diff)
gentoo auto-resync : 21:02:2023 - 20:25:12
Diffstat (limited to 'dev-python/bottle/bottle-0.12.24.ebuild')
-rw-r--r--dev-python/bottle/bottle-0.12.24.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/bottle/bottle-0.12.24.ebuild b/dev-python/bottle/bottle-0.12.24.ebuild
new file mode 100644
index 000000000000..e7fcb7168349
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="
+ https://bottlepy.org/
+ https://github.com/bottlepy/bottle/
+ https://pypi.org/project/bottle/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e '/scripts/d' -i setup.py || die
+
+ # Remove test file requiring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}