summaryrefslogtreecommitdiff
path: root/dev-python/bottle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
commitd37f8725bb68034ef10d8882fb4411a49f2f666e (patch)
tree2b530ee04815bacc1dc051db24c2727d3056b77b /dev-python/bottle
parent171d09fa1f429aa43835c618a2c21753ad5209a4 (diff)
gentoo auto-resync : 21:02:2023 - 20:25:12
Diffstat (limited to 'dev-python/bottle')
-rw-r--r--dev-python/bottle/Manifest2
-rw-r--r--dev-python/bottle/bottle-0.12.24.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/bottle/Manifest b/dev-python/bottle/Manifest
index e33b4d0e7cc4..2f3a5588a157 100644
--- a/dev-python/bottle/Manifest
+++ b/dev-python/bottle/Manifest
@@ -1,3 +1,5 @@
DIST bottle-0.12.23.tar.gz 73965 BLAKE2B ccd3dc3aad5c4c8b6899f55f03550cf9178e51788c27ece9808e1cff92693cc09dab145be16f814d29dae02ce53374a0470b2c4b032bc66a0ec2b1a11ec5ca44 SHA512 0550aa95680dd79d9c63c5de854845377183c86015893d9ee4e67126eca201582ef79d40ff0d1cbe79fe8a250118a775c63102475e337e18cfc1a65afe18f62a
+DIST bottle-0.12.24.tar.gz 74146 BLAKE2B a6bb638a0cba4d5fadbcb3a1a303b66a04f3c4df84e34b87d4a9bb22178de943123403d2851bd28504cf9d91380af95dd108e3b84825a93a6345cbe39fec0c33 SHA512 a3bc4bdc1376aef6c7b5784de18bfaac83e2c0c279fb2c3c3a8322871c68516e858b8c82cfff9291d41a66b906c13099c9d1037184bc48ff6f4ef0783b048f9b
EBUILD bottle-0.12.23.ebuild 1219 BLAKE2B 546f0ca5fc2bf5a7dfb0c902b4c29153497b7069811de4f67c7c82f142edf17313a3ba035e57d670f4937256c9fe202e53337118f8f4fa72a0f72286022a4cdc SHA512 1db32bbf79460dfb88afc9c4e8ce82cd7d32fc5f0fe9004b632cc8daa7c9563b12744659d1224f902448ba0c6788e71404085a724a079d22aaad8988b255eb2e
+EBUILD bottle-0.12.24.ebuild 1180 BLAKE2B 5777f6292108d4d5b38db98938eec670032945f079789f3fd429ea0cfb231a4e349fd1c6f1918d886a148817139c18e80682671dfecd540e31f668d1a97f9c68 SHA512 a3fa4ab6beaa32a3238013dbd4e4817e01156be423da6f6e9adfb4fa95af31a2d4522505d5ce3c738cad05b53cb0892264d40436a954a6068a6f71e8cd3b79ef
MISC metadata.xml 389 BLAKE2B fa960ae3a5dbead30cd7bc7617f87d5f2597716f6edef3a2af4ab15a7f45cfab6db98d77335a24fd792a6161dde7b7ff183d934e19cf69f7e1b2c72485cafd00 SHA512 06b65bd22b74e1e77597e65872d6ecc471e97848b05c02a0e2d35f98499d4c56164a15093ea96b9e55a59ed2624bed2adfb45d58d4a79c426087ca2ddf89f6b4
diff --git a/dev-python/bottle/bottle-0.12.24.ebuild b/dev-python/bottle/bottle-0.12.24.ebuild
new file mode 100644
index 000000000000..e7fcb7168349
--- /dev/null
+++ b/dev-python/bottle/bottle-0.12.24.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="A fast and simple micro-framework for small web-applications"
+HOMEPAGE="
+ https://bottlepy.org/
+ https://github.com/bottlepy/bottle/
+ https://pypi.org/project/bottle/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e '/scripts/d' -i setup.py || die
+
+ # Remove test file requiring connection to network
+ rm test/test_server.py || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Templating support" dev-python/mako
+ elog "Due to problems with bottle.py being in /usr/bin (see bug #474874)"
+ elog "we do as most other distros and do not install the script anymore."
+ elog "If you do want/have to call it directly rather than through your app,"
+ elog "please use the following instead:"
+ elog ' `python -m bottle`'
+}