summaryrefslogtreecommitdiff
path: root/dev-python/blurb/blurb-1.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/blurb/blurb-1.0.7.ebuild
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/blurb/blurb-1.0.7.ebuild')
-rw-r--r--dev-python/blurb/blurb-1.0.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/blurb/blurb-1.0.7.ebuild b/dev-python/blurb/blurb-1.0.7.ebuild
new file mode 100644
index 000000000000..fe85e9a6768e
--- /dev/null
+++ b/dev-python/blurb/blurb-1.0.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
+HOMEPAGE="https://github.com/python/core-workflow/tree/master/blurb"
+SRC_URI="https://files.pythonhosted.org/packages/29/4f/268f9aa095cbcf53253c665fd0f5103f22dccf246fe317ab9c5c481b38f5/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/blurb-setuptools.patch"
+)