summaryrefslogtreecommitdiff
path: root/dev-python/blurb
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /dev-python/blurb
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'dev-python/blurb')
-rw-r--r--dev-python/blurb/Manifest4
-rw-r--r--dev-python/blurb/blurb-1.0.7.ebuild22
-rw-r--r--dev-python/blurb/files/blurb-setuptools.patch14
-rw-r--r--dev-python/blurb/metadata.xml23
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/blurb/Manifest b/dev-python/blurb/Manifest
new file mode 100644
index 000000000000..b65f94945e72
--- /dev/null
+++ b/dev-python/blurb/Manifest
@@ -0,0 +1,4 @@
+AUX blurb-setuptools.patch 522 BLAKE2B a035fc3282d11845219a442494de83e385210421bcb45edf6780bf93d7cf43c2f3995394f862425f2c0e897357e8f187c07a2ff3b0dbc2aa9c932bfdfd83e69a SHA512 51348af10150ac288df6e4cc2d8c573b43432e18014234b4a68672518f02ef968dd26c4abe8d59dc8d6c64417cc86e770a5295635fa88356c526a580c201c581
+DIST blurb-1.0.7.tar.gz 21248 BLAKE2B 931a0db30447f5a41c956f15dac2bd967efd8a85d4837782e02af24edc31dec03d3fab27f22db1dafe334dcfc79b133cf99092fc28b59c190b1182d1f897e0bb SHA512 d84fdc0a7ecec1207a58a748f6d33343504d0b090166c91b05e9b3c2eb125fff890194539204386bdc7a1e0a595d2cb80d54d873045941491d26ca85cb55ac98
+EBUILD blurb-1.0.7.ebuild 613 BLAKE2B d75f7fe4058e6c94540030fdfe93e60e82c393d2367d1bfece10bf923fc519b13ad52aecd74ddc9d771bfc56f3ad608d17dbccfc6a7a73159e2dc49e0e6a1e1e SHA512 70cff4ebaf1a12abd118fd12ed0d73ff6bc0fc392db9490ee0ed1b196a20c286c790ffd733cbb3c729e5e680bf3d86b56666406ba4bb241d301fa3b856041db1
+MISC metadata.xml 976 BLAKE2B 0d391aee3be51752f3cdb2406bacbc4a0bb45bfbebc3b2bc67b788af647faf92bf1308fbc9f51426d4c540f8e89edc8bb6f5c967000a56e40b134270ac8336bd SHA512 611315d86b3ccbecfadc3c38be45e0322221a0f1065d5d59d717a33fbf66f510274b6cb772ca3468ec76e21613ddb88cb547dc3a4e7b50d638c3fe811ed61abb
diff --git a/dev-python/blurb/blurb-1.0.7.ebuild b/dev-python/blurb/blurb-1.0.7.ebuild
new file mode 100644
index 000000000000..fe85e9a6768e
--- /dev/null
+++ b/dev-python/blurb/blurb-1.0.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2018 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
+HOMEPAGE="https://github.com/python/core-workflow/tree/master/blurb"
+SRC_URI="https://files.pythonhosted.org/packages/29/4f/268f9aa095cbcf53253c665fd0f5103f22dccf246fe317ab9c5c481b38f5/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/blurb-setuptools.patch"
+)
diff --git a/dev-python/blurb/files/blurb-setuptools.patch b/dev-python/blurb/files/blurb-setuptools.patch
new file mode 100644
index 000000000000..4845af98285a
--- /dev/null
+++ b/dev-python/blurb/files/blurb-setuptools.patch
@@ -0,0 +1,14 @@
+diff -u blurb-1.0.7.orig/setup.py blurb-1.0.7/setup.py
+--- blurb-1.0.7.orig/setup.py 1969-12-31 16:00:00.000000000 -0800
++++ blurb-1.0.7/setup.py 2018-11-05 14:58:55.148518033 -0800
+@@ -1,7 +1,7 @@
+ #!/usr/bin/env python
+ # setup.py generated by flit for tools that don't yet use PEP 517
+
+-from distutils.core import setup
++from setuptools import setup
+
+ entry_points = \
+ {'console_scripts': ['blurb = blurb:main']}
+Only in blurb-1.0.7: .setup.py.un~
+Common subdirectories: blurb-1.0.7.orig/tests and blurb-1.0.7/tests
diff --git a/dev-python/blurb/metadata.xml b/dev-python/blurb/metadata.xml
new file mode 100644
index 000000000000..a68165db0ed5
--- /dev/null
+++ b/dev-python/blurb/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <longdescription lang="en">
+ blurb is a tool designed to rid CPython core development of the scourge of
+ Misc/NEWS conflicts.
+
+ The core concept: split Misc/NEWS into many separate files that, when
+ concatenated back together in sorted order, reconstitute the original
+ Misc/NEWS file. After that, Misc/NEWS could be deleted from the CPython
+ repo and thereafter rendered on demand (e.g. when building a release).
+ When checking in a change to CPython, the checkin process will write
+ out a new file that sorts into the correct place, using a filename
+ unlikely to have a merge conflict.
+ </longdescription>
+</pkgmetadata>