summaryrefslogtreecommitdiff
path: root/dev-python/aniso8601
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-31 18:57:01 +0000
commit69051588e2f955485fe5d45d45e616bc60a2de57 (patch)
treeef8699cca7ce3773b1de747b167ceeacdc60cb92 /dev-python/aniso8601
parentd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (diff)
gentoo resync : 31.01.2021
Diffstat (limited to 'dev-python/aniso8601')
-rw-r--r--dev-python/aniso8601/Manifest4
-rw-r--r--dev-python/aniso8601/aniso8601-8.0.0.ebuild2
-rw-r--r--dev-python/aniso8601/aniso8601-8.1.1.ebuild19
3 files changed, 23 insertions, 2 deletions
diff --git a/dev-python/aniso8601/Manifest b/dev-python/aniso8601/Manifest
index 39f6d6c9bbac..c9ab0f496c76 100644
--- a/dev-python/aniso8601/Manifest
+++ b/dev-python/aniso8601/Manifest
@@ -1,3 +1,5 @@
DIST aniso8601-8.0.0.tar.gz 37007 BLAKE2B bb5f42928308fab7746cbea364c03db4813b1b25883495d0488eb755e14f465300662b07c4ccfd03328a0c0f07ed87056ccc13f2652648c4838b0433740fc3ab SHA512 1e6c43f77993e829833d819f7c2b9b1d31f30ca46e258faac0e0b3be864da07436ae34f05710309302477bb3eede5966c95ef3b124c9b353b306c2272dc4cb9d
-EBUILD aniso8601-8.0.0.ebuild 520 BLAKE2B c2ca8a08c88eee1b72124028a0c3d8fe2168b9f923c7922fcf246705f7a544a9d76f8cb3d33785ae269bb82662d423bcaabd53f8aeaf17c4e7667670e962f4b9 SHA512 c7e6be54f58aeca1f65cc3888672a9987b1c351d0264441c4dcb58f72154ae1d1df4f916e51c04c1d03f268655e48c6eca2bf4f7d9b0845f4f9974883897806a
+DIST aniso8601-8.1.1.tar.gz 39143 BLAKE2B d72161923e164032e1b9e4ed317d688d70b2a16bec6c23966f76abbb4d10f24def18df41fcca4e8f45e6145f4f067ec5483f34305a33eee3445d4706df188a99 SHA512 f9c3412c5e7dec04cca56df5806a747779848adb90137293368b4d50c365692b1d1f792a00f57172925229ccdee34ef5b50cc2d06f4c9b4d697c651e5a2e3674
+EBUILD aniso8601-8.0.0.ebuild 518 BLAKE2B 0e6723ba05fdff5cf73bfba1f2c32a7a180edda059212324ab415b1f0f2b4d5f2c4ad5382bedbadc01ce862f6d2c0a302ba1c8013797b358d31c19b5d899a6c0 SHA512 09981827bf44df392c89b8c12410268f0404f9a08071f6eb46131340040b6d4dc7c03f3cbf47b0f61368ff3f9b5d45068c1203d022d872b67825dfafad0c61c7
+EBUILD aniso8601-8.1.1.ebuild 522 BLAKE2B 46cab7fecb64e924bec095fa03d9351604e7a1a163f11f0d7d9418d2539b86f3f0f86d7fe6e6ccc5c2daeae03fa6e8c24ae632795e7c96dc367e3aea2dd643b2 SHA512 5cad45128bae9d96eccfbb831449b6a046deed8edd22b8215c36b673e51a41ab930aa363c66fd20f82525383fb9c60ad4b452e8dfe9c413f6adcd899fc225cca
MISC metadata.xml 410 BLAKE2B a90d3f803fe5f99e83046d3cc1ebf5ec993c18e8aafdbddc2c8928a6b5e4b961e511a027366a59b4133fad65c425393513c1ab9960c32d8119c06da7ec113ee9 SHA512 2ea6cd3e1268d3e14817f2334e3946671161422cba8be852cb7b74ddbe60ceb89fdde07629d2d8be5677cb2820e05db7f67c335a95b74d42a3e23a91a7d8b603
diff --git a/dev-python/aniso8601/aniso8601-8.0.0.ebuild b/dev-python/aniso8601/aniso8601-8.0.0.ebuild
index f05ce8ac852a..160d472e0c6d 100644
--- a/dev-python/aniso8601/aniso8601-8.0.0.ebuild
+++ b/dev-python/aniso8601/aniso8601-8.0.0.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7,8} pypy3 )
inherit distutils-r1
diff --git a/dev-python/aniso8601/aniso8601-8.1.1.ebuild b/dev-python/aniso8601/aniso8601-8.1.1.ebuild
new file mode 100644
index 000000000000..298eb44a792c
--- /dev/null
+++ b/dev-python/aniso8601/aniso8601-8.1.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A library for parsing ISO 8601 strings"
+HOMEPAGE="https://bitbucket.org/nielsenb/aniso8601/ https://pypi.org/project/aniso8601/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND=">=dev-python/python-dateutil-2.7.3[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest