summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-complexity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-php/sebastian-complexity
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-php/sebastian-complexity')
-rw-r--r--dev-php/sebastian-complexity/Manifest4
-rw-r--r--dev-php/sebastian-complexity/files/autoload-2.0.2.php20
-rw-r--r--dev-php/sebastian-complexity/metadata.xml12
-rw-r--r--dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild27
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-php/sebastian-complexity/Manifest b/dev-php/sebastian-complexity/Manifest
new file mode 100644
index 000000000000..5739dbe4c7c4
--- /dev/null
+++ b/dev-php/sebastian-complexity/Manifest
@@ -0,0 +1,4 @@
+AUX autoload-2.0.2.php 999 BLAKE2B f2911660d2a7bc493eb51c09fbf2dad9c50e4eaf68646f9305bc9cdd7f9da73784f85958d0824a7702f45faa1e4c4d85ccb489ed8664424cbf2760a1c4bb7bc3 SHA512 60717d6899d262a5386a0f2d55cb9e05f3d1fac35fc7c1c582a1a515bad1000d8055338f5cddb218e93f85d781a730b839de38e63cf81f654280300a974c3cf0
+DIST sebastian-complexity-2.0.2.tar.gz 4979 BLAKE2B f742e0f3057d7d24963236e2b32841cd6d8fb9b14870e2bfbe1d84cb737008428c9e00db28f5c2f42a61877a4282b3dbd5935c9a3ea4cf93401691c43bab40df SHA512 04773cfac3622eca3d859e9180f8eb5582e3a4124837b2e2cb536b052eeac6fe19dbae81ddbdcc88405de0ff0b202140609e7a5eb435af54faac4b1262c780e7
+EBUILD sebastian-complexity-2.0.2.ebuild 696 BLAKE2B a7b38b2b572d5a3e9d7395d83a85c8ae59f1bec5a64f1154a99704dfeb6e66fafe8eea95204b2f3eee6bca71fdff030eade02bc80e3ccce01ad8a0cf18aa35fe SHA512 90387cbcf10f0e759dbe506891f27d41a9ddc2cfab2d97530299c872b89f0a276fd4808fa181011182a48b29c0cfaa960fb07c6217b8c3a751594adb9e296b2f
+MISC metadata.xml 357 BLAKE2B e4c24d19e2932df1116131191dac6c68aed9dc4f099671ea0dc335d06a0eea00c70af4ccd2af292681da3733792191d2e2f76de13861ea28f7c7eb2779b2e6b2 SHA512 f83043dddb170e90d53870e17ef1285fa9f73c894282599e728e84db5d73a2d7cd7f702be00ba5ec613be73f2da351d4d9a64833e3ccc79292ea143c60bd0e48
diff --git a/dev-php/sebastian-complexity/files/autoload-2.0.2.php b/dev-php/sebastian-complexity/files/autoload-2.0.2.php
new file mode 100644
index 000000000000..07eb31b7ee93
--- /dev/null
+++ b/dev-php/sebastian-complexity/files/autoload-2.0.2.php
@@ -0,0 +1,20 @@
+<?php
+/* Autoloader for dev-php/sebastian-complexity */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ [
+ 'sebastianbergmann\complexity\calculator' => '/Calculator.php',
+ 'sebastianbergmann\complexity\complexity' => '/Complexity/Complexity.php',
+ 'sebastianbergmann\complexity\complexitycollection' => '/Complexity/ComplexityCollection.php',
+ 'sebastianbergmann\complexity\complexitycollectioniterator' => '/Complexity/ComplexityCollectionIterator.php',
+ 'sebastianbergmann\complexity\complexitycalculatingvisitor' => '/Visitor/ComplexityCalculatingVisitor.php',
+ 'sebastianbergmann\complexity\cyclomaticcomplexitycalculatingvisitor' => '/Visitor/CyclomaticComplexityCalculatingVisitor.php',
+ 'sebastianbergmann\complexity\exception' => '/Exception/Exception.php',
+ 'sebastianbergmann\complexity\runtimeexception' => '/Exception/RuntimeException.php',
+ ],
+ __DIR__
+);
diff --git a/dev-php/sebastian-complexity/metadata.xml b/dev-php/sebastian-complexity/metadata.xml
new file mode 100644
index 000000000000..3f4b99635ae6
--- /dev/null
+++ b/dev-php/sebastian-complexity/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/complexity</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild b/dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild
new file mode 100644
index 000000000000..21c42e69830b
--- /dev/null
+++ b/dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Library for calculating the complexity of PHP code units"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ dev-php/nikic-php-parser
+ >=dev-lang/php-7.3:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Complexity
+ doins -r src/*
+ newins "${FILESDIR}/autoload-2.0.2.php" autoload.php
+}