summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild')
-rw-r--r--dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild b/dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild
new file mode 100644
index 000000000000..21c42e69830b
--- /dev/null
+++ b/dev-php/sebastian-complexity/sebastian-complexity-2.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Library for calculating the complexity of PHP code units"
+HOMEPAGE="https://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ dev-php/nikic-php-parser
+ >=dev-lang/php-7.3:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Complexity
+ doins -r src/*
+ newins "${FILESDIR}/autoload-2.0.2.php" autoload.php
+}