summaryrefslogtreecommitdiff
path: root/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild')
-rw-r--r--dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild b/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
new file mode 100644
index 000000000000..542ec6f226c2
--- /dev/null
+++ b/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+DESCRIPTION="Watt's Up Monitoring Daemon"
+HOMEPAGE="https://dev.gentoo.org/~robbat2/wattsup-daemon/"
+SRC_URI="https://dev.gentoo.org/~robbat2/wattsup-daemon/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+BDEPEND="dev-perl/Device-SerialPort
+ dev-perl/Time-TAI64
+ virtual/perl-Time-HiRes"
+RDEPEND="${BDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-openrc.patch" )
+
+mydoc="AUTHORS doc/wattsup_spec_v442.txt"
+
+src_install() {
+ perl-module_src_install
+ newinitd gentoo/wattsup-daemon.initd wattsup-daemon
+ newconfd gentoo/wattsup-daemon.confd wattsup-daemon
+}