summaryrefslogtreecommitdiff
path: root/dev-perl/WattsUp-Daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-perl/WattsUp-Daemon
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-perl/WattsUp-Daemon')
-rw-r--r--dev-perl/WattsUp-Daemon/Manifest2
-rw-r--r--dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild29
-rw-r--r--dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch9
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/WattsUp-Daemon/Manifest b/dev-perl/WattsUp-Daemon/Manifest
index 7c1fef609785..f7a4ee316f4b 100644
--- a/dev-perl/WattsUp-Daemon/Manifest
+++ b/dev-perl/WattsUp-Daemon/Manifest
@@ -1,3 +1,5 @@
+AUX WattsUp-Daemon-0.4-openrc.patch 485 BLAKE2B 870dc91de9073a3a6df34dbd379855307ca4ca5d09684887b338b5ccb5522c08cdd06683f37ccbb4a65972eeb849c019f9679c7cd6b66647032f3585eec2bf4e SHA512 1b00918b4768e2cae1a2e70876e3959b2d6e4a551f4ba293d4666bb9a8cf9acf69f0b166b12522b7d69107f25e9cc8e81b54295ad11aa8e04860d8a77284d775
DIST WattsUp-Daemon-0.4.tar.gz 13505 BLAKE2B 6c7befa6736a4669252255fa806baa46d9cd78d1100d6fc1cbf456da45ee944541fd5ee9b073054064869908a040c320e134686425f44c7070d86cacf2b74a1b SHA512 38060e541673f37a693168ebe0064d6f80c4095ce0f227783926203e5af54f4c7ec252127f78b89a58bf8c1543a440dd6a26e7c464e381e058c55e940d64e368
EBUILD WattsUp-Daemon-0.4-r1.ebuild 715 BLAKE2B 739b776acfd4ec00b8d9e740388d9f78be5d0419bc84d2b7a1511436640d514c351a5414bb48d41fef624360782cb0696eee8e25b856b0e26973625237c413b4 SHA512 57d223f92aa58d9d56f21935900a5cf5a53280fc13665cc5b1307965420baee00393af4fa7a53a65b692e0ca3f006d719e83847f50ab91889678b9a6363c828d
+EBUILD WattsUp-Daemon-0.4-r2.ebuild 695 BLAKE2B de388e66e030daf5bd4d7cd4958c3a956decc41e6da21daa5f0c80300b15dcd2fbde2846a72785de8a6720ea952978f389b58507050b534a9079fc3f6ec13aac SHA512 61287f3f8765fe53fad8a6a408aa34f6edc12994df9627ee07afd99cc8328f079f2c5cfc54288fe7d4c194ae9d69917a37f944b361bbf5a598bc5903d7dacb91
MISC metadata.xml 330 BLAKE2B b138b236895c061b453abe042d91e8ff75cc81efe4497ff4797695827b4dc8e98c97e2631aa3b2d7d65a38360be964ed0440f8ac76f69c591eb86988e5c015a1 SHA512 02836288e5d9a15745ae56b21b776381198dc8bb71a89d28b3c3bccc20f031097f5d29e3d647e71108aa4b735aa086a95c05327a014c565920b3d5eb0f4992df
diff --git a/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild b/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
new file mode 100644
index 000000000000..542ec6f226c2
--- /dev/null
+++ b/dev-perl/WattsUp-Daemon/WattsUp-Daemon-0.4-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module
+
+DESCRIPTION="Watt's Up Monitoring Daemon"
+HOMEPAGE="https://dev.gentoo.org/~robbat2/wattsup-daemon/"
+SRC_URI="https://dev.gentoo.org/~robbat2/wattsup-daemon/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+BDEPEND="dev-perl/Device-SerialPort
+ dev-perl/Time-TAI64
+ virtual/perl-Time-HiRes"
+RDEPEND="${BDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-openrc.patch" )
+
+mydoc="AUTHORS doc/wattsup_spec_v442.txt"
+
+src_install() {
+ perl-module_src_install
+ newinitd gentoo/wattsup-daemon.initd wattsup-daemon
+ newconfd gentoo/wattsup-daemon.confd wattsup-daemon
+}
diff --git a/dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch b/dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch
new file mode 100644
index 000000000000..6741775c799f
--- /dev/null
+++ b/dev-perl/WattsUp-Daemon/files/WattsUp-Daemon-0.4-openrc.patch
@@ -0,0 +1,9 @@
+diff -ruN WattsUp-Daemon-0.4.orig/gentoo/wattsup-daemon.initd WattsUp-Daemon-0.4/gentoo/wattsup-daemon.initd
+--- WattsUp-Daemon-0.4.orig/gentoo/wattsup-daemon.initd 2007-12-02 09:44:07.000000000 +0100
++++ WattsUp-Daemon-0.4/gentoo/wattsup-daemon.initd 2021-04-24 15:51:40.437424079 +0200
+@@ -1,4 +1,4 @@
+-#!/sbin/runscript
++#!/sbin/openrc-run
+ # Copyright 2007, Robin H. Johnson <robbat2@gentoo.org>
+ # You can use and redistribute WattsUpDaemon under the same terms as Perl itself.
+