summaryrefslogtreecommitdiff
path: root/dev-perl/Locale-gettext
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Locale-gettext
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Locale-gettext')
-rw-r--r--dev-perl/Locale-gettext/Locale-gettext-1.70.0.ebuild22
-rw-r--r--dev-perl/Locale-gettext/Manifest4
-rw-r--r--dev-perl/Locale-gettext/files/Locale-gettext-1.70.0-no-dot-inc.patch90
-rw-r--r--dev-perl/Locale-gettext/metadata.xml12
4 files changed, 128 insertions, 0 deletions
diff --git a/dev-perl/Locale-gettext/Locale-gettext-1.70.0.ebuild b/dev-perl/Locale-gettext/Locale-gettext-1.70.0.ebuild
new file mode 100644
index 000000000000..334b9924f962
--- /dev/null
+++ b/dev-perl/Locale-gettext/Locale-gettext-1.70.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_NAME=gettext
+DIST_AUTHOR=PVANDRY
+DIST_VERSION=1.07
+inherit perl-module
+
+DESCRIPTION="A Perl module for accessing the GNU locale utilities"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-devel/gettext"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+PATCHES=("${FILESDIR}/${P}-no-dot-inc.patch")
+S="${WORKDIR}/${PN}-${DIST_VERSION}"
diff --git a/dev-perl/Locale-gettext/Manifest b/dev-perl/Locale-gettext/Manifest
new file mode 100644
index 000000000000..1af377ba90d2
--- /dev/null
+++ b/dev-perl/Locale-gettext/Manifest
@@ -0,0 +1,4 @@
+AUX Locale-gettext-1.70.0-no-dot-inc.patch 2576 BLAKE2B 026fe094e7cff34eb0192076a333349f6ec875c59eeca21658a4f16b8817b796b4830d5540ad77d0ca71d47dfbb5a009256bf1d8ccd1d2fb6da91be72ddeddc0 SHA512 af169db6991e968e29dcc760030919cc619e4bd9f13b4f20d707914674aa5c53dabeaec0e9f29254dbf9250fc96e6ace36a86a50b1dc5af0e1573bf4485047d2
+DIST gettext-1.07.tar.gz 8651 BLAKE2B ecdc105303c0b494d53f985ca0d789d75da33abc85e8579a43af1658d6faa18e2564e18fc6613548acc2add4ce847d03769c1fbe29dbb760b9498f4b251cbb1c SHA512 d3716a597d586ee2ff29472ca7b13aaf67770299de31e5f12abafebc879bbe4a1e1dbc0025cf4f3dc29992955f26cffc3be387d974c3911af095d5b49e67a1c6
+EBUILD Locale-gettext-1.70.0.ebuild 657 BLAKE2B 68912a8db02faf4993ca4469d510b24fe0ad4aac0283d7c257fab29b8b98440c9a41c1f121b656a90d2477b21f718650636de6f9dfcc052e4d41b9ec2dda5e59 SHA512 4971084c8528387539055a9155370c71a4f2db08c6c7bccec8f14668d86e6bed30c1fe381021591215a2d03ccd766f326a18938b558a1a43901e6ff0471aea1d
+MISC metadata.xml 393 BLAKE2B bbff5a6ce4a93c66bbc706cf416835858db71b6ce566478b67af59afe2cf42057ba053ac1d23721dce435c47982437811ebd9cde52f91474116191efab62f316 SHA512 368d7a37c00a186733e33eeaa01c12fdfed50f2f45c66bc88d0dfddcfd063aacb6c0953aa76737d8f9f5c2ed392e0eef41279975cf2cfad7fb423b8ca29592b0
diff --git a/dev-perl/Locale-gettext/files/Locale-gettext-1.70.0-no-dot-inc.patch b/dev-perl/Locale-gettext/files/Locale-gettext-1.70.0-no-dot-inc.patch
new file mode 100644
index 000000000000..962d90cdae7c
--- /dev/null
+++ b/dev-perl/Locale-gettext/files/Locale-gettext-1.70.0-no-dot-inc.patch
@@ -0,0 +1,90 @@
+From 08c1f219ae209b2475e5a1b025caceb10cb4a41b Mon Sep 17 00:00:00 2001
+From: Kim Vandry <vandry@TZoNE.ORG>
+Date: Sun, 28 May 2017 19:11:30 +0100
+Subject: Update tests to work with @INC that does not contain '.'
+
+Perl 5.25.11 removes '.' from the default @INC, and this breaks
+`require "test_data/gen_test_data.pl"` due to not being able to assume
+./test_data/gen_test_data.pl is in the @INC load path, and due to
+`require` treating paths without leading "/" or "./" as search paths.
+
+This change implements the first solution suggested by the reporter of
+the bug: Re-organise test dependencies into a dedicated directory such
+as `t/lib` and load that path into @INC with `use lib 't/lib'`.
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=121458
+Bug: https://bugs.gentoo.org/617048
+---
+ MANIFEST | 2 +-
+ t/frconvert.t | 3 ++-
+ t/jaconvert.t | 3 ++-
+ {test_data => t/lib}/gen_test_data.pl | 0
+ t/raw.t | 3 ++-
+ 5 files changed, 7 insertions(+), 4 deletions(-)
+ rename {test_data => t/lib}/gen_test_data.pl (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index 9604b91..e9f6e08 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -8,7 +8,7 @@ t/jaconvert.t
+ t/raw.t
+ t/use.t
+ test_data/foo.po
+-test_data/gen_test_data.pl
++t/lib/gen_test_data.pl
+ test_data/jaeuc.po
+ MANIFEST
+ META.yml Module YAML meta-data (added by MakeMaker)
+diff --git a/t/frconvert.t b/t/frconvert.t
+index 2bca28b..9a4f4f5 100644
+--- a/t/frconvert.t
++++ b/t/frconvert.t
+@@ -1,8 +1,9 @@
+ #!/usr/bin/env perl -w
+ use strict;
+ use Test;
++use lib 't/lib';
+ BEGIN { plan tests => 1 }
+-require "test_data/gen_test_data.pl";
++require "gen_test_data.pl";
+
+ gen("foo");
+ use Locale::gettext;
+diff --git a/t/jaconvert.t b/t/jaconvert.t
+index 5794dc4..b95c883 100644
+--- a/t/jaconvert.t
++++ b/t/jaconvert.t
+@@ -1,8 +1,9 @@
+ #!/usr/bin/env perl -w
+ use strict;
+ use Test;
++use lib 't/lib';
+ BEGIN { plan tests => 1 }
+-require "test_data/gen_test_data.pl";
++require "gen_test_data.pl";
+
+ gen("jaeuc");
+ use Locale::gettext;
+diff --git a/test_data/gen_test_data.pl b/t/lib/gen_test_data.pl
+similarity index 100%
+rename from test_data/gen_test_data.pl
+rename to t/lib/gen_test_data.pl
+diff --git a/t/raw.t b/t/raw.t
+index 1e1cf14..7439397 100644
+--- a/t/raw.t
++++ b/t/raw.t
+@@ -1,8 +1,9 @@
+ #!/usr/bin/env perl -w
+ use strict;
+ use Test;
++use lib 't/lib';
+ BEGIN { plan tests => 1 }
+-require "test_data/gen_test_data.pl";
++require "gen_test_data.pl";
+
+ gen("foo");
+ use Locale::gettext;
+--
+2.14.3
+
diff --git a/dev-perl/Locale-gettext/metadata.xml b/dev-perl/Locale-gettext/metadata.xml
new file mode 100644
index 000000000000..30ac1ae4e237
--- /dev/null
+++ b/dev-perl/Locale-gettext/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">gettext</remote-id>
+ <remote-id type="cpan-module">Locale::gettext</remote-id>
+ </upstream>
+</pkgmetadata>