summaryrefslogtreecommitdiff
path: root/dev-perl/Const-Fast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Const-Fast
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Const-Fast')
-rw-r--r--dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild32
-rw-r--r--dev-perl/Const-Fast/Manifest3
-rw-r--r--dev-perl/Const-Fast/metadata.xml24
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild b/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..a7a12a5bd500
--- /dev/null
+++ b/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.014
+inherit perl-module
+
+DESCRIPTION="Facility for creating read-only scalars, arrays, and hashes"
+
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ >=dev-perl/Sub-Exporter-Progressive-0.1.7
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.21.0
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST=do
+mytargets="install"
diff --git a/dev-perl/Const-Fast/Manifest b/dev-perl/Const-Fast/Manifest
new file mode 100644
index 000000000000..946ec9ef58fb
--- /dev/null
+++ b/dev-perl/Const-Fast/Manifest
@@ -0,0 +1,3 @@
+DIST Const-Fast-0.014.tar.gz 12886 BLAKE2B 7df39021b15d15b8d3bde7519921bf7a3a685cc15be5706e880f10aaa1e7df299f3eb268807524c64a28413d35cfff7dd07a704b721641e61aaca666f17ede04 SHA512 89258205fe31aa5a60759ed955e6dae305de69f4bc08251242a82eec9e37251b045908585c470106ed9047f604d3292eb3231c80504b29734966b58b8402a929
+EBUILD Const-Fast-0.14.0-r1.ebuild 652 BLAKE2B 81a84cdb25916894cb4b7748a7b28ef84779062c5c0c923bc9615a205eed70fde28941a20d7469cbb089ed078fdf4da990639ed7dc9fd22f3b19bcf7c00c81e1 SHA512 425c0058f90e8f9d6230670740cdd919156489d424c2fd3d36c1af0df6200cb5afed10a193db264addf59dfeb3749e5ab4b63b5bcb997341b68b4551a82729c6
+MISC metadata.xml 911 BLAKE2B 6814427d9855cb4d16ea42a1b46f146c1ab5e6c9c9eb9ae4e2bf5d20213e1581e8800ccc67c3e9aafcd65dca31ed65dd3668fa445472970a22f1fc9bf00764cf SHA512 8716a9bed0f681742c5353b6b604a60b0c01e1e1fd657a726a89301b1fae8e22491ed28940ccbe11158f674a398bc2ee5842458a9c7ec3b4dec70bddbfadccc5
diff --git a/dev-perl/Const-Fast/metadata.xml b/dev-perl/Const-Fast/metadata.xml
new file mode 100644
index 000000000000..f81ffd083697
--- /dev/null
+++ b/dev-perl/Const-Fast/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+</maintainer>
+<longdescription lang="en">
+ This the only function of this module and it is exported by
+ default. It takes a scalar, array or hash left-value as first
+ argument, and a list of one or more values depending on the type of
+ the first argument as the value for the variable. It will set the
+ variable to that value and subsequently make it read-only. Arrays
+ and hashes will be made deeply read-only.
+</longdescription>
+<upstream>
+ <remote-id type="cpan">Const-Fast</remote-id>
+ <remote-id type="cpan-module">Const::Fast</remote-id>
+</upstream>
+</pkgmetadata>